Bug 522310 - Memory leak on show/hide
Memory leak on show/hide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Peng Huang
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-09 23:20 EDT by Ignacio Vazquez-Abrams
Modified: 2009-09-15 02:19 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-15 02:19:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ignacio Vazquez-Abrams 2009-09-09 23:20:53 EDT
ibus-1.1.0.20090612-3.fc11.x86_64
ibus-anthy-1.1.0.20090814-1.fc11.x86_64

The IBus python process leaks memory when Anthy is the active IME and the bar is shown and/or hidden (not entirely certain which). It does not leak with LaTeX or Compose IMEs. Have not tested others.
Comment 1 Ignacio Vazquez-Abrams 2009-09-09 23:30:45 EDT
Still leaky after upgrading to ibus-1.1.0.20090829-1.fc11.x86_64.
Comment 2 fujiwara 2009-09-10 00:01:30 EDT
I cannot reproduce your problem.

How do you check the memory leaks?

> when Anthy is the active IME and the bar is shown and/or hidden

Do you mean left click on ibus icon on gnome-panel?
I tried to click 'Anthy' and 'No input method' but I could not see any problems.
Comment 3 Ignacio Vazquez-Abrams 2009-09-10 00:46:46 EDT
(In reply to comment #2) 
> How do you check the memory leaks?

I run top in a terminal and sort by RSS.

> > when Anthy is the active IME and the bar is shown and/or hidden
> 
> Do you mean left click on ibus icon on gnome-panel?

When I use the hotkey to show/hide the bar (Ctrl-Space here).

It takes a few cycles to see a change in top, but when I hold down the hotkey it rapidly shows and hides the bar, and in top I see the RSS increase at about 4MB per second.
Comment 4 fujiwara 2009-09-10 03:06:28 EDT
It seems /usr/share/ibus/ui/gtk/main.py and PyGTK debug is needed.
It would need time and the file belongs to ibus so I transfer this at the moment.

I could see the issue when Type Shift + o, n after top is invoked.
Comment 5 Peng Huang 2009-09-10 04:39:51 EDT
Fixed in upstream. I will build it later.
Comment 6 Peng Huang 2009-09-15 02:19:06 EDT
Fixed in ibus-1_2_0_20090915-1_fc12

Note You need to log in before you can comment on or make changes to this bug.