Bug 522334 - setroubleshoot: SELinux is preventing the wineserver from using potentially mislabeled files (regcd80000.tmp).
Summary: setroubleshoot: SELinux is preventing the wineserver from using potentia...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:09afd33f61d...
: 522335 522336 522337 522339 522340 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-10 05:57 UTC by shmuel siegel
Modified: 2009-09-10 12:26 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-10 12:23:51 UTC


Attachments (Terms of Use)

Description shmuel siegel 2009-09-10 05:57:48 UTC
The following was filed automatically by setroubleshoot:

Summary:

SELinux is preventing the wineserver from using potentially mislabeled files
(regcd80000.tmp).

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux has denied wineserver access to potentially mislabeled file(s)
(regcd80000.tmp). This means that SELinux will not allow wineserver to use these
files. It is common for users to edit files in their home directory or tmp
directories and then move (mv) them to system directories. The problem is that
the files end up with the wrong file context which confined applications are not
allowed to access.

Allowing Access:

If you want wineserver to access this files, you need to relabel them using
restorecon -v 'regcd80000.tmp'. You might want to relabel the entire directory
using restorecon -R -v ''.

Additional Information:

Source Context                unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:user_home_t:s0
Target Objects                regcd80000.tmp [ file ]
Source                        wineserver
Source Path                   /usr/bin/wineserver
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           wine-core-1.1.29-1.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.30-4.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Permissive
Plugin Name                   home_tmp_bad_labels
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.31-0.204.rc9.fc12.i686 #1 SMP Sat Sep 5
                              21:01:10 EDT 2009 i686 i686
Alert Count                   1
First Seen                    Wed 09 Sep 2009 09:11:20 AM IDT
Last Seen                     Wed 09 Sep 2009 09:11:20 AM IDT
Local ID                      a9356038-1443-4245-95cc-d5302684ba2b
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1252476680.196:235): avc:  denied  { create } for  pid=3288 comm="wineserver" name="regcd80000.tmp" scontext=unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1252476680.196:235): arch=40000003 syscall=5 success=yes exit=138 a0=955bb28 a1=80c1 a2=1b6 a3=0 items=0 ppid=1 pid=3288 auid=500 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=1 comm="wineserver" exe="/usr/bin/wineserver" subj=unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023 key=(null)


audit2allow suggests:

#============= wine_t ==============
allow wine_t user_home_t:file create;

Comment 1 Daniel Walsh 2009-09-10 12:23:51 UTC
Fixed in selinux-policy-3.6.30-5.fc12.noarch

Comment 2 Daniel Walsh 2009-09-10 12:24:33 UTC
*** Bug 522335 has been marked as a duplicate of this bug. ***

Comment 3 Daniel Walsh 2009-09-10 12:24:53 UTC
*** Bug 522336 has been marked as a duplicate of this bug. ***

Comment 4 Daniel Walsh 2009-09-10 12:25:51 UTC
*** Bug 522337 has been marked as a duplicate of this bug. ***

Comment 5 Daniel Walsh 2009-09-10 12:26:26 UTC
*** Bug 522339 has been marked as a duplicate of this bug. ***

Comment 6 Daniel Walsh 2009-09-10 12:26:52 UTC
*** Bug 522340 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.