Bug 522339 - setroubleshoot: SELinux is preventing the winevdm.exe from using potentially mislabeled files (/home/shmuels/.wine/drive_c/windows/fonts/sserife.fon).
Summary: setroubleshoot: SELinux is preventing the winevdm.exe from using potenti...
Keywords:
Status: CLOSED DUPLICATE of bug 522334
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:093e6432ca4...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-10 06:01 UTC by shmuel siegel
Modified: 2009-09-10 12:26 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-10 12:26:26 UTC


Attachments (Terms of Use)

Description shmuel siegel 2009-09-10 06:01:55 UTC
The following was filed automatically by setroubleshoot:

Summary:

SELinux is preventing the winevdm.exe from using potentially mislabeled files
(/home/shmuels/.wine/drive_c/windows/fonts/sserife.fon).

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux has denied winevdm.exe access to potentially mislabeled file(s)
(/home/shmuels/.wine/drive_c/windows/fonts/sserife.fon). This means that SELinux
will not allow winevdm.exe to use these files. It is common for users to edit
files in their home directory or tmp directories and then move (mv) them to
system directories. The problem is that the files end up with the wrong file
context which confined applications are not allowed to access.

Allowing Access:

If you want winevdm.exe to access this files, you need to relabel them using
restorecon -v '/home/shmuels/.wine/drive_c/windows/fonts/sserife.fon'. You might
want to relabel the entire directory using restorecon -R -v
'/home/shmuels/.wine/drive_c/windows/fonts'.

Additional Information:

Source Context                unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023
Target Context                system_u:object_r:user_home_t:s0
Target Objects                /home/shmuels/.wine/drive_c/windows/fonts/sserife.
                              fon [ file ]
Source                        winevdm.exe
Source Path                   /usr/bin/wine-preloader
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           wine-core-1.1.29-1.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.30-4.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Permissive
Plugin Name                   home_tmp_bad_labels
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.31-0.204.rc9.fc12.i686 #1 SMP Sat Sep 5
                              21:01:10 EDT 2009 i686 i686
Alert Count                   1
First Seen                    Wed 09 Sep 2009 09:11:25 AM IDT
Last Seen                     Wed 09 Sep 2009 09:11:25 AM IDT
Local ID                      7854c2f3-c219-44b0-bc2a-170ca1dc028d
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1252476685.180:246): avc:  denied  { read } for  pid=5568 comm="winevdm.exe" name="sserife.fon" dev=sda6 ino=228307 scontext=unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023 tcontext=system_u:object_r:user_home_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1252476685.180:246): arch=40000003 syscall=5 success=yes exit=18 a0=1146a8 a1=8000 a2=0 a3=0 items=0 ppid=1 pid=5568 auid=500 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=1 comm="winevdm.exe" exe="/usr/bin/wine-preloader" subj=unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023 key=(null)


audit2allow suggests:

#============= wine_t ==============
allow wine_t user_home_t:file read;

Comment 1 Daniel Walsh 2009-09-10 12:26:26 UTC

*** This bug has been marked as a duplicate of bug 522334 ***


Note You need to log in before you can comment on or make changes to this bug.