Bug 522358 - DPMS fails on Intel Mobile 4 Series Chipset
Summary: DPMS fails on Intel Mobile 4 Series Chipset
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kristian Høgsberg
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 522588 522877 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-10 06:51 UTC by Bob Arendt
Modified: 2009-10-07 17:17 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-07 17:17:14 UTC


Attachments (Terms of Use)
Xorg.0.log w/ KMS, drm.debug=1 set on boot (41.32 KB, text/plain)
2009-09-10 06:51 UTC, Bob Arendt
no flags Details
dmesg w/ KMS and drm.debug=1 (54.08 KB, text/plain)
2009-09-10 06:52 UTC, Bob Arendt
no flags Details
Smolt profile for this Dell Inspiron 1545 laptop (7.00 KB, text/plain)
2009-09-10 06:53 UTC, Bob Arendt
no flags Details

Description Bob Arendt 2009-09-10 06:51:37 UTC
Created attachment 360434 [details]
Xorg.0.log w/ KMS, drm.debug=1 set on boot

from F12 intel test day, DPMS does not work -- there's no obvious failure, the screen saver and screen power management just never kicks in.

Comment 1 Bob Arendt 2009-09-10 06:52:22 UTC
Created attachment 360435 [details]
dmesg w/ KMS and drm.debug=1

Comment 2 Bob Arendt 2009-09-10 06:53:12 UTC
Created attachment 360436 [details]
Smolt profile for this Dell Inspiron 1545 laptop

Comment 3 Caspar Zhang 2009-09-10 07:36:44 UTC
+1

Comment 4 Gregory Maxwell 2009-09-10 22:52:14 UTC
on this hardware too: http://www.smolts.org/client/show/pub_f9e226dd-89fa-490f-9839-f841f59dc49c

Comment 5 Jonathan Pritchard 2009-09-11 15:28:04 UTC
Same here,
http://www.smolts.org/client/show/pub_9940d6f1-5115-4ce7-831e-4b90895eacc6

Comment 6 Antal KICSI 2009-09-11 17:54:01 UTC
I have a same problem as Bob Arendt with 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device

Smolt profile : http://www.smolts.org/client/show/pub_50c9b678-9c49-4072-b7a6-c5eb9a36c342

Comment 7 Aaron Clark 2009-09-12 18:21:59 UTC
I experienced the exact same problem.

[aaron@calcifer ~]$ lspci -s 00:02.0 -nn
00:02.0 VGA compatible controller [0300]: Intel Corporation 82945G/GZ Integrated Graphics Controller [8086:2772] (rev 02)

Comment 8 Tim Lauridsen 2009-09-13 13:21:48 UTC
same here>

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)

http://www.smolts.org/client/show/pub_22f9a5c3-69eb-4481-b552-6c5c70dabb45

ThinkPad T60

Comment 9 Adam Williamson 2009-09-18 04:14:11 UTC
*** Bug 522877 has been marked as a duplicate of this bug. ***

Comment 10 Adam Williamson 2009-09-18 04:23:37 UTC
*** Bug 522588 has been marked as a duplicate of this bug. ***

Comment 11 Adam Williamson 2009-09-18 04:23:58 UTC
*** Bug 522844 has been marked as a duplicate of this bug. ***

Comment 12 Antal KICSI 2009-10-06 20:48:31 UTC
With desktop-i386-20091002.15.iso from 
 
 http://alt.fedoraproject.org/pub/alt/nightly-composes/desktop/

the DMPS problem seems to be solved - the screensaver and screen power
management kicks in on time.

Video hardware : 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device

Smolt profile :
http://www.smolts.org/client/show/pub_50c9b678-9c49-4072-b7a6-c5eb9a36c342

Comment 13 Adam Williamson 2009-10-06 22:42:23 UTC
Bob, can you confirm?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 14 Bob Arendt 2009-10-07 03:51:50 UTC
I should be able to re-test tomorrow.  I'll start with:
http://alt.fedoraproject.org/pub/alt/nightly-composes/desktop/desktop-x86_64-20091005.20.iso
and and "yum update" to current rawhide.

Comment 15 Michal Nowak 2009-10-07 08:19:59 UTC
It's working for me for some time.

Comment 16 Adam Williamson 2009-10-07 17:17:14 UTC
two confirmations is good...Bob, re-open if you don't verify the fix. thanks!

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers


Note You need to log in before you can comment on or make changes to this bug.