Bug 522472 - setroubleshoot: SELinux is preventing wine "read" access on /usr/lib/locale/locale-archive.
Summary: setroubleshoot: SELinux is preventing wine "read" access on /usr/lib/loc...
Keywords:
Status: CLOSED DUPLICATE of bug 522471
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:314dca7f690...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-10 12:25 UTC by Sebastiano M. Cossu
Modified: 2009-09-10 14:17 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-10 14:17:27 UTC


Attachments (Terms of Use)

Description Sebastiano M. Cossu 2009-09-10 12:25:59 UTC
The following was filed automatically by setroubleshoot:

Sommario:

SELinux is preventing wine "read" access on /usr/lib/locale/locale-archive.

Descrizione dettagliata:

SELinux denied access requested by wine. It is not expected that this access is
required by wine and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Abilitazione accesso in corso:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi) against this package.

Informazioni aggiuntive:

Contesto della sorgente       unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023
Contesto target               unconfined_u:object_r:locale_t:s0
Oggetti target                /usr/lib/locale/locale-archive [ file ]
Sorgente                      wine
Percorso della sorgente       /bin/bash
Porta                         <Sconosciuto>
Host                          (removed)
Sorgente Pacchetti RPM        bash-4.0.28-3.fc12
Pacchetti RPM target          glibc-common-2.10.90-21
RPM della policy              selinux-policy-3.6.30-4.fc12
Selinux abilitato             True
Tipo di policy                targeted
MLS abilitato                 True
Modalità Enforcing           Enforcing
Nome plugin                   catchall
Host Name                     (removed)
Piattaforma                   Linux (removed) 2.6.31-0.204.rc9.fc12.i686 #1 SMP Sat
                              Sep 5 21:01:10 EDT 2009 i686 i686
Conteggio avvisi              3
Primo visto                   gio 10 set 2009 04:55:33 CEST
Ultimo visto                  gio 10 set 2009 04:55:33 CEST
ID locale                     2f9c8333-5644-4989-bea4-7e3a74d8c5f8
Numeri di linea               

Messaggi Raw Audit            

node=(removed) type=AVC msg=audit(1252551333.198:55): avc:  denied  { read } for  pid=9226 comm="wine" path="/usr/lib/locale/locale-archive" dev=dm-0 ino=49993 scontext=unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:locale_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1252551333.198:55): arch=40000003 syscall=192 success=no exit=-1210609664 a0=0 a1=200000 a2=1 a3=2 items=0 ppid=1 pid=9226 auid=500 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=1 comm="wine" exe="/bin/bash" subj=unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023 key=(null)


audit2allow suggests:

#============= wine_t ==============
allow wine_t locale_t:file read;

Comment 1 Daniel Walsh 2009-09-10 14:17:27 UTC

*** This bug has been marked as a duplicate of bug 522471 ***


Note You need to log in before you can comment on or make changes to this bug.