Bug 52249 - mogrify doesn't modify the file
Summary: mogrify doesn't modify the file
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: ImageMagick   
(Show other bugs)
Version: roswell
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-21 23:57 UTC by Need Real Name
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-21 23:57:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-08-21 23:57:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.8-ac7 i686; Nav)

Description of problem:
If I try a mogrify -crop 10% mymimage.tif, it is supposed to crop 10% on
all axis. The program is really doing it but it doesn't replace the
original file.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. mogrify -crop 10% yourimage.tif
2. see if the original changed

	

Actual Results:  The original is not touched although the program is really
doing its job but save the result in /tmp. You can see that if you run
mogrify with the -verbose option.

Expected Results:  The original should be replace by the transformed image.

Additional info:

I use the plain 5.3.7 from the cd.

Comment 1 Bernhard Rosenkraenzer 2001-08-22 10:33:14 UTC
Works for me with 5.3.8-2


Comment 2 Mathieu Chouquet-Stringer 2001-11-04 17:42:11 UTC
I hate to add a reply to myself but I just upgraded my 7.1 box to 7.2 and the
mogrify command still doesn't work for me (I say this because my 7.1 box was the
only one on which it was working)...

I use this mogrify -fuzz 100 -crop 0x0 01\ -\ Fedreal\ Reserve.tif

It is supposed to remove the black borders around the picture.
You can download the picture at:
http://mchouque.free.fr/01_-_Fedreal_Reserve.tif

I tested on 4 different boxes with 7.2, same result...

I'm testing right now with the plain version from the ImageMagick website, I
will let you know...

Comment 3 Mathieu Chouquet-Stringer 2001-11-04 19:51:32 UTC
Well, I just tried the binaries from 7.1 and it worked well... Either 5.3.9 or
5.4.0.2 from the ImageMagick website are giving me strange results...
I'll stick with 5.2.7-2 from RH 7.1


Note You need to log in before you can comment on or make changes to this bug.