Bug 522504 - rpm -Va reports md5 errors when there are no md5 errors
Summary: rpm -Va reports md5 errors when there are no md5 errors
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Panu Matilainen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-10 14:49 UTC by mathieu.lacage
Modified: 2009-09-15 07:47 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-15 07:47:15 UTC


Attachments (Terms of Use)

Description mathieu.lacage 2009-09-10 14:49:07 UTC
Description of problem:
rpm -Va reports md5 errors on some binaries but I verified the checksum by hand with a pristine binary package and the binaries appear to be correct

Version-Release number of selected component (if applicable):
[mathieu@mathieu-laptop bin]$ rpm -qa |grep 'rpm\|bash'
rpmfusion-free-release-11-1.noarch
deltarpm-3.4-16.fc11.x86_64
rpm-python-4.7.1-1.fc11.x86_64
rpmlint-0.90-1.fc11.noarch
redhat-rpm-config-9.0.3-11.fc11.noarch
rpm-libs-4.7.1-1.fc11.x86_64
rpmfusion-nonfree-release-11-1.noarch
rpm-4.7.1-1.fc11.x86_64
rpm-build-4.7.1-1.fc11.x86_64
bash-4.0-7.fc11.x86_64
bash-4.0-8.fc11.x86_64
[mathieu@mathieu-laptop bin]$ 


How reproducible:
Always

Steps to Reproduce:
1. sudo rpm -Va >/tmp/output
2. grep emacs /tmp/output
3. grep bash /tmp/output
 
Actual results:
S.5......    /usr/bin/emacs-23.1
S.5......    /bin/bash

Expected results:
No output for these binaries

Additional info:
Here is what I did to verify the binary:
[mathieu@mathieu-laptop tmp]$ sudo prelink -u -o /tmp/bash /bin/bash
[mathieu@mathieu-laptop tmp]$ md5sum /tmp/bash
dd6532e38c2eda1d19403c024a3d6602  /tmp/bash
[mathieu@mathieu-laptop tmp]$ wget ftp://195.220.108.108/linux/fedora/updates/11/x86_64/bash-4.0-8.fc11.x86_64.rpm
[mathieu@mathieu-laptop tmp]$ rpm2cpio ./bash-4.0-8.fc11.x86_64.rpm |cpio -idmv
[mathieu@mathieu-laptop tmp]$ cd bin
[mathieu@mathieu-laptop bin]$ md5sum bash
dd6532e38c2eda1d19403c024a3d6602  bash

Comment 1 Panu Matilainen 2009-09-15 07:47:15 UTC
Note how you have two versions of bash (an presumably the same deal with emacs) in the rpmdb, from a partially failed upgrade or such:
bash-4.0-7.fc11.x86_64
bash-4.0-8.fc11.x86_64

The /bin/bash binary differs between those two versions, so one of them passes and the other one fails verification as both can't be right. NOTABUG, you'll just want to clean up the leftover entries. "package-cleanup --cleandupes" should do the trick.


Note You need to log in before you can comment on or make changes to this bug.