Bug 52252 - Default settings in wireless.opts cause redhat-config-network to fail
Default settings in wireless.opts cause redhat-config-network to fail
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Harald Hoyer
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-21 21:36 EDT by Scott Russell
Modified: 2007-04-18 12:36 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-24 05:14:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Russell 2001-08-21 21:36:16 EDT
Description of Problem:

The default options in the /etc/pcmcia/wireless.opts file for the wvlan_cs
include the setting of several options including ESSID, MODE, RATE, and
KEY. Because the redhat-config-network tool does not write all these
options if the values are left empty the settings in wireless.opts take hold. 

For example if the user has a wireless lan with the following settings:

ESSID = HomeLAN
MODE = Managed
FREQ = ""
CHANNEL = 1
RATE = auto
KEY = ""

The redhat-config-network tools writes the following values to the ifcfg
script:

CHANNEL=1
ESSID=HomeLAN
MODE=Managed
RATE=auto

The missing FREQ and KEY values are then used from wireless.opts which may
cause the configuration of the network interface to fail.

Version-Release number of selected component (if applicable):
redhat-config-network-0.7.3-1
kernel-pcmcia-cs-3.1.27-7
initscripts-6.20-1
Roswell 2 i386 Laptop Install RC1 / BETA4 release

How Reproducible:
100%

Steps to Reproduce:
See above example.
Comment 1 Arjan van de Ven 2001-08-22 08:58:45 EDT
I think redhat-config-network should write out all the values;
shipping defaults that have no ESSID/key is not what I want.
Comment 2 Glen Foster 2001-08-22 18:10:14 EDT
This defect is considered SHOULD-FIX for Fairfax.
Comment 3 Scott Russell 2001-08-23 23:53:24 EDT
Still waiting for updated redhat-config-network to re test this. Please update
this bug when a new test package becomes available.
Comment 4 Harald Hoyer 2001-08-24 05:14:36 EDT
fixed in CVS ... have to make a package now ... patience ;)

Note You need to log in before you can comment on or make changes to this bug.