Bug 522572 - setroubleshoot: SELinux is preventing start "getattr" access on /var/cache/fontconfig/12b26b760a24f8b4feb03ad48a333a72-x86.cache-2.
Summary: setroubleshoot: SELinux is preventing start "getattr" access on /var/cac...
Keywords:
Status: CLOSED DUPLICATE of bug 522562
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:08555a83d8f...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-10 17:58 UTC by Sebastiano M. Cossu
Modified: 2009-09-10 18:13 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-10 18:13:10 UTC


Attachments (Terms of Use)

Description Sebastiano M. Cossu 2009-09-10 17:58:34 UTC
The following was filed automatically by setroubleshoot:

Sommario:

SELinux is preventing start "getattr" access on
/var/cache/fontconfig/12b26b760a24f8b4feb03ad48a333a72-x86.cache-2.

Descrizione dettagliata:

[start has a permissive type (wine_t). This access was not denied.]

SELinux denied access requested by start. It is not expected that this access is
required by start and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Abilitazione accesso in corso:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi) against this package.

Informazioni aggiuntive:

Contesto della sorgente       unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023
Contesto target               unconfined_u:object_r:fonts_t:s0
Oggetti target                /var/cache/fontconfig/12b26b760a24f8b4feb03ad48a33
                              3a72-x86.cache-2 [ file ]
Sorgente                      start
Percorso della sorgente       /usr/bin/wine-preloader
Porta                         <Sconosciuto>
Host                          (removed)
Sorgente Pacchetti RPM        wine-core-1.1.29-1.fc12
Pacchetti RPM target          
RPM della policy              selinux-policy-3.6.30-4.fc12
Selinux abilitato             True
Tipo di policy                targeted
MLS abilitato                 True
Modalità Enforcing           Enforcing
Nome plugin                   catchall
Host Name                     (removed)
Piattaforma                   Linux (removed) 2.6.31-0.204.rc9.fc12.i686 #1 SMP Sat
                              Sep 5 21:01:10 EDT 2009 i686 i686
Conteggio avvisi              1
Primo visto                   gio 10 set 2009 04:55:36 CEST
Ultimo visto                  gio 10 set 2009 04:55:36 CEST
ID locale                     322cad69-34c8-4d66-87d3-de8619f481aa
Numeri di linea               

Messaggi Raw Audit            

node=(removed) type=AVC msg=audit(1252551336.188:94): avc:  denied  { getattr } for  pid=9226 comm="start" path="/var/cache/fontconfig/12b26b760a24f8b4feb03ad48a333a72-x86.cache-2" dev=dm-0 ino=49258 scontext=unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:fonts_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1252551336.188:94): arch=40000003 syscall=197 success=yes exit=0 a0=9 a1=32ee9c a2=682d0ff4 a3=3 items=0 ppid=1 pid=9226 auid=500 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=1 comm="start" exe="/usr/bin/wine-preloader" subj=unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023 key=(null)


audit2allow suggests:

#============= wine_t ==============
allow wine_t fonts_t:file getattr;

Comment 1 Daniel Walsh 2009-09-10 18:13:10 UTC

*** This bug has been marked as a duplicate of bug 522562 ***


Note You need to log in before you can comment on or make changes to this bug.