Bug 522581 - setroubleshoot: SELinux is preventing start "unix_read unix_write" access on <Unknown>.
Summary: setroubleshoot: SELinux is preventing start "unix_read unix_write" acces...
Keywords:
Status: CLOSED DUPLICATE of bug 522580
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:4a7c31c168f...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-10 18:23 UTC by Sebastiano M. Cossu
Modified: 2009-09-10 19:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-10 19:40:05 UTC


Attachments (Terms of Use)

Description Sebastiano M. Cossu 2009-09-10 18:23:14 UTC
The following was filed automatically by setroubleshoot:

Sommario:

SELinux is preventing start "unix_read unix_write" access on <Unknown>.

Descrizione dettagliata:

[start has a permissive type (wine_t). This access was not denied.]

SELinux denied access requested by start. It is not expected that this access is
required by start and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Abilitazione accesso in corso:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi) against this package.

Informazioni aggiuntive:

Contesto della sorgente       unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023
Contesto target               unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023
Oggetti target                None [ shm ]
Sorgente                      start
Percorso della sorgente       /usr/bin/wine-preloader
Porta                         <Sconosciuto>
Host                          (removed)
Sorgente Pacchetti RPM        wine-core-1.1.29-1.fc12
Pacchetti RPM target          
RPM della policy              selinux-policy-3.6.30-4.fc12
Selinux abilitato             True
Tipo di policy                targeted
MLS abilitato                 True
Modalità Enforcing           Enforcing
Nome plugin                   catchall
Host Name                     (removed)
Piattaforma                   Linux (removed) 2.6.31-0.204.rc9.fc12.i686 #1 SMP Sat
                              Sep 5 21:01:10 EDT 2009 i686 i686
Conteggio avvisi              3
Primo visto                   gio 10 set 2009 04:55:42 CEST
Ultimo visto                  gio 10 set 2009 04:55:42 CEST
ID locale                     cf8ef416-de62-4269-b671-2e9fb0600357
Numeri di linea               

Messaggi Raw Audit            

node=(removed) type=AVC msg=audit(1252551342.784:96): avc:  denied  { unix_read unix_write } for  pid=9226 comm="start" key=0 scontext=unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023 tclass=shm

node=(removed) type=AVC msg=audit(1252551342.784:96): avc:  denied  { read write } for  pid=9226 comm="start" key=0 scontext=unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023 tclass=shm

node=(removed) type=AVC msg=audit(1252551342.784:96): avc:  denied  { read write } for  pid=9226 comm="start" path=2F535953563030303030303030202864656C6574656429 dev=tmpfs ino=1605658 scontext=unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:tmpfs_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1252551342.784:96): arch=40000003 syscall=117 success=yes exit=0 a0=15 a1=18801a a2=0 a3=32faa8 items=0 ppid=1 pid=9226 auid=500 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=1 comm="start" exe="/usr/bin/wine-preloader" subj=unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023 key=(null)


audit2allow suggests:

#============= wine_t ==============
allow wine_t self:shm { unix_read read write unix_write };
allow wine_t tmpfs_t:file { read write };

Comment 1 Daniel Walsh 2009-09-10 19:40:05 UTC

*** This bug has been marked as a duplicate of bug 522580 ***


Note You need to log in before you can comment on or make changes to this bug.