Bug 522594 - setroubleshoot: SELinux is preventing the wineserver from using potentially mislabeled files (socket).
Summary: setroubleshoot: SELinux is preventing the wineserver from using potentia...
Keywords:
Status: CLOSED DUPLICATE of bug 522580
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:58b29927086...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-10 19:16 UTC by Sebastiano M. Cossu
Modified: 2009-09-10 19:41 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-10 19:41:30 UTC


Attachments (Terms of Use)

Description Sebastiano M. Cossu 2009-09-10 19:16:40 UTC
The following was filed automatically by setroubleshoot:

Sommario:

SELinux is preventing the wineserver from using potentially mislabeled files
(socket).

Descrizione dettagliata:

[wineserver has a permissive type (wine_t). This access was not denied.]

SELinux has denied wineserver access to potentially mislabeled file(s) (socket).
This means that SELinux will not allow wineserver to use these files. It is
common for users to edit files in their home directory or tmp directories and
then move (mv) them to system directories. The problem is that the files end up
with the wrong file context which confined applications are not allowed to
access.

Abilitazione accesso in corso:

If you want wineserver to access this files, you need to relabel them using
restorecon -v 'socket'. You might want to relabel the entire directory using
restorecon -R -v 'socket'.

Informazioni aggiuntive:

Contesto della sorgente       unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023
Contesto target               unconfined_u:object_r:tmp_t:s0
Oggetti target                socket [ dir ]
Sorgente                      wineserver
Percorso della sorgente       /usr/bin/wineserver
Porta                         <Sconosciuto>
Host                          (removed)
Sorgente Pacchetti RPM        wine-core-1.1.29-1.fc12
Pacchetti RPM target          
RPM della policy              selinux-policy-3.6.30-4.fc12
Selinux abilitato             True
Tipo di policy                targeted
MLS abilitato                 True
Modalità Enforcing           Enforcing
Nome plugin                   home_tmp_bad_labels
Host Name                     (removed)
Piattaforma                   Linux (removed) 2.6.31-0.204.rc9.fc12.i686 #1 SMP Sat
                              Sep 5 21:01:10 EDT 2009 i686 i686
Conteggio avvisi              1
Primo visto                   gio 10 set 2009 04:56:04 CEST
Ultimo visto                  gio 10 set 2009 04:56:04 CEST
ID locale                     019fbcd5-482c-4ec0-9a54-f7f2abdb058a
Numeri di linea               

Messaggi Raw Audit            

node=(removed) type=AVC msg=audit(1252551364.180:108): avc:  denied  { remove_name } for  pid=9231 comm="wineserver" name="socket" dev=dm-0 ino=142464 scontext=unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:tmp_t:s0 tclass=dir

node=(removed) type=AVC msg=audit(1252551364.180:108): avc:  denied  { unlink } for  pid=9231 comm="wineserver" name="socket" dev=dm-0 ino=142464 scontext=unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:tmp_t:s0 tclass=sock_file

node=(removed) type=SYSCALL msg=audit(1252551364.180:108): arch=40000003 syscall=10 success=yes exit=0 a0=8093c09 a1=ca9cd8 a2=ca8ff4 a3=ca9cc0 items=0 ppid=1 pid=9231 auid=500 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=1 comm="wineserver" exe="/usr/bin/wineserver" subj=unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023 key=(null)


audit2allow suggests:

#============= wine_t ==============
allow wine_t tmp_t:dir remove_name;
allow wine_t tmp_t:sock_file unlink;

Comment 1 Daniel Walsh 2009-09-10 19:41:30 UTC

*** This bug has been marked as a duplicate of bug 522580 ***


Note You need to log in before you can comment on or make changes to this bug.