Bug 522604 - perl-5.8.8-27.el5 (or earlier) downgraded File::Temp to older version
Summary: perl-5.8.8-27.el5 (or earlier) downgraded File::Temp to older version
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: perl
Version: 5.4
Hardware: All
OS: Linux
low
urgent
Target Milestone: rc
: ---
Assignee: Marcela Mašláňová
QA Contact: BaseOS QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-10 19:56 UTC by Jonathan Manton
Modified: 2009-09-14 15:53 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-14 15:53:16 UTC


Attachments (Terms of Use)

Description Jonathan Manton 2009-09-10 19:56:23 UTC
Description of problem:
When upgrading to RHEL 5.4, the File::Temp module was downgraded from 0.18 to 0.16.  This breaks existing code on a web server using mod_perl.

Version-Release number of selected component (if applicable):
perl-5.8.8-27.el5

How reproducible:

On my recently upgraded RHEL 5.4 system:

  #rpm -qf /usr/lib/perl5/5.8.8/File/Temp.pm 
  perl-5.8.8-27.el5

  # grep VERSION /usr/lib/perl5/5.8.8/File/Temp.pm
  $VERSION = '0.16';

  # ls -l /usr/lib/perl5/5.8.8/File/Temp.pm 
  -rw-r--r-- 1 root root 64935 Jul  2 04:50 /usr/lib/perl5/5.8.8/File/Temp.pm



On an older RHEL 5 machine where perl has not been upgraded:

  # rpm -qf /usr/lib/perl5/5.8.8/File/Temp.pm 
  perl-5.8.8-10

  # grep VERSION /usr/lib/perl5/5.8.8/File/Temp.pm
  $VERSION = '0.18';

  # ls -l /usr/lib/perl5/5.8.8/File/Temp.pm 
  -r--r--r-- 1 root root 66420 Jan 21  2007 /usr/lib/perl5/5.8.8/File/Temp.pm



Steps to Reproduce:
1.  Upgrade a RHEL machine with perl-5.8.8-10 installed to version 5.8.8-27.el5.
2.  Any perl code that depends on the perl File::Temp module being >= 0.18 stops working.
3.
  
Actual results:
File::Temp is now listed as version 0.16

Expected results:
The File::Temp version number should be monotonically increasing across RHEL releases.

Additional info:

From the changelog in the -27.el5 spec file, We have these two entries:
* Tue Jun 23 2009 Marcela MaÅ¡láÅová <mmaslano@redhat.com> - 4:5.8.8-25.el5
- 458851 remove update of module - the cleanup function was already in
  the previous version

and

* Thu Mar 12 2009 Marcela MaÅ¡láÅová <mmaslano@redhat.com> - 4:5.8.8-22.el5
- File::Temp updated to 0.18
- Resolves: rhbz#458851


In light of this, I don't quite understand how my 5.8.8-10 install has a version of 0.18 in the File::Temp module.  The file on my older system clearly says it is version 0.18, and has a last modified date of Jan 21, 2007.

Comment 2 Marcela Mašláňová 2009-09-14 11:52:02 UTC
Build perl-5.8.8-10.el5_2.3 contains File::Temp 0.16.

The new build of perl (perl-5.8.8-27.el5) contains mentioned changes but both were done internally. The previous version 5.8.8-10 contains still the same version 0.16. Are you sure that you didn't use cpan on your computer?

Comment 3 Jonathan Manton 2009-09-14 15:31:44 UTC
Yes.  Usually CPAN installs things in /usr/lib/perl5/site_perl/5.8.8.  

It looks like it over-wrote the /usr/lib/perl5/5.8.8/File/Temp.pm file at some point in the past (which is very disturbing).

You can close this bug, it was my error.

Comment 4 Marcela Mašláňová 2009-09-14 15:53:16 UTC
Thank you for verification.


Note You need to log in before you can comment on or make changes to this bug.