Bug 522617 - No kickstart channels imported into Satellite from satellite-sync
Summary: No kickstart channels imported into Satellite from satellite-sync
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Satellite Synchronization
Version: 530
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
Assignee: Pradeep Kilambi
QA Contact: Brandon Perkins
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-10 20:29 UTC by Kyle Gonzales
Modified: 2009-09-10 20:53 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-10 20:53:54 UTC


Attachments (Terms of Use)

Description Kyle Gonzales 2009-09-10 20:29:16 UTC
Description of problem:
New install of RHN Satellite on RHEL5.4 x86-64.  Running in a VM on RHEL5.4, 2 Gb of RAM, 2 cores.

Install of Satellite went without issue.  Ran the following to populate the channels:
satellite-sync -c rhel-x86_64-server-5 -c rhn-tools-rhel-x86_64-server-5

Packages and metadata were pulled down and imported into Satellite.  However, NO kickstart trees were imported.  satellite-sync command has be re-run, with the same result.  Server has been rebooted multiple times.  Same result.


Version-Release number of selected component (if applicable):
Clean install of RHEL5.4
Clean install of RHN Satellite 5.3


How reproducible:
Every time so far.

Steps to Reproduce:
1.  Build Satellite 5.3 on RHEL 5.4
2.  Run "satellite-sync -c rhel-x86_64-server-5 -c rhn-tools-rhel-x86_64-server-5"
3.  See no kickstart channels
  
Actual results:
No kickstart channels, cannot create a kickstart because of this.

Expected results:
RHEL5 x86-64 kickstart channels.

Additional info:

Comment 1 Kyle Gonzales 2009-09-10 20:53:54 UTC
The problem was caused by cobblerd not being started on the Satellite, and not chkconfig'd on.  Starting cobblerd caused the kickstart trees to show up.  I do not know WHY cobblerd was not started, but the issue has been solved.


Note You need to log in before you can comment on or make changes to this bug.