Bug 522641 - setroubleshoot: SELinux is preventing xinetd "getattr" access on <Unknown>.
Summary: setroubleshoot: SELinux is preventing xinetd "getattr" access on <Unk...
Keywords:
Status: CLOSED DUPLICATE of bug 522639
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:05462126254...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-10 21:57 UTC by Matěj Cepl
Modified: 2019-05-23 15:30 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-11 13:10:41 UTC


Attachments (Terms of Use)

Description Matěj Cepl 2009-09-10 21:57:37 UTC
The following was filed automatically by setroubleshoot:

Souhrn:

SELinux is preventing xinetd "getattr" access on <Unknown>.

Podrobný popis:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by xinetd. It is not expected that this access
is required by xinetd and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Povolení přístupu:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi) against this package.

Další informace:

Kontext zdroje                unconfined_u:system_r:inetd_t:s0-s0:c0.c1023
Kontext cíle                 unconfined_u:system_r:inetd_t:s0-s0:c0.c1023
Objekty cíle                 None [ netlink_route_socket ]
Zdroj                         xinetd
Cesta zdroje                  /usr/sbin/xinetd
Port                          <Neznámé>
Počítač                    (removed)
RPM balíčky zdroje          xinetd-2.3.14-23.fc12
RPM balíčky cíle           
RPM politiky                  selinux-policy-3.6.30-4.fc12
Selinux povolen               True
Typ politiky                  targeted
MLS povoleno                  True
Vynucovací režim            Permissive
Název zásuvného modulu     catchall
Název počítače            (removed)
Platforma                     Linux (removed) 2.6.31-0.204.rc9.fc12.x86_64 #1 SMP
                              Sat Sep 5 20:45:55 EDT 2009 x86_64 x86_64
Počet upozornění           1
Poprvé viděno               Čt 10. září 2009, 20:28:38 CEST
Naposledy viděno             Čt 10. září 2009, 20:28:38 CEST
Místní ID                   2420bfba-0aa5-48bb-a86b-4c82906e7b39
Čísla řádků              

Původní zprávy auditu      

node=(removed) type=AVC msg=audit(1252607318.815:45): avc:  denied  { getattr } for  pid=2350 comm="xinetd" scontext=unconfined_u:system_r:inetd_t:s0-s0:c0.c1023 tcontext=unconfined_u:system_r:inetd_t:s0-s0:c0.c1023 tclass=netlink_route_socket

node=(removed) type=SYSCALL msg=audit(1252607318.815:45): arch=c000003e syscall=51 success=yes exit=0 a0=8 a1=7fff5f058520 a2=7fff5f05852c a3=7fff5f0584f0 items=0 ppid=2349 pid=2350 auid=500 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=1 comm="xinetd" exe="/usr/sbin/xinetd" subj=unconfined_u:system_r:inetd_t:s0-s0:c0.c1023 key=(null)


audit2allow suggests:

#============= inetd_t ==============
allow inetd_t self:netlink_route_socket getattr;

Comment 1 Daniel Walsh 2009-09-11 13:10:41 UTC

*** This bug has been marked as a duplicate of bug 522639 ***


Note You need to log in before you can comment on or make changes to this bug.