Bug 522645 - Hard lockup with Nvidia G72 [GeForce 7300 SE] after fast user switch
Summary: Hard lockup with Nvidia G72 [GeForce 7300 SE] after fast user switch
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ben Skeggs
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 522646 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-10 22:22 UTC by Mike Gahagan
Modified: 2009-09-29 16:55 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-29 16:55:32 UTC


Attachments (Terms of Use)

Description Mike Gahagan 2009-09-10 22:22:09 UTC
Description of problem:
Following the fastuserswitching test case on the 10-9-2009 Nouveau test day, I got a hard system lock-up when attempting to switching back to the first user. 

Version-Release number of selected component (if applicable):
testday-20090909

How reproducible:
suspect consistantly, only tried once

Steps to Reproduce:
1.https://fedoraproject.org/wiki/QA:Testcase_nouveau_fastuserswitch
2.lock-up occured after switching back to the first user.
3.
  
Actual results:


Expected results:
no lock-up

Additional info:
F11 smolt profile
http://www.smolts.org/client/show_all/pub_47ec75db-36e8-44ba-9e61-b93981ce89f6

Comment 1 Ben Skeggs 2009-09-14 01:26:20 UTC
*** Bug 522646 has been marked as a duplicate of this bug. ***

Comment 2 Ben Skeggs 2009-09-16 23:23:48 UTC
Can you update to kernel 2.6.31-23.fc12 and retry please, this should be fixed.

Comment 3 Adam Williamson 2009-09-17 20:29:35 UTC
if it's not convenient for you to do a rawhide install, you can get nightly live builds here:

http://alt.fedoraproject.org/pub/alt/nightly-composes/desktop/

probably tomorrow's will have a new enough kernel.

ben, best to set to MODIFIED if you think it's fixed, rather than NEEDINFO.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 4 Mike Gahagan 2009-09-17 20:35:53 UTC
Thanks! a nightly live image is definitely preferable as I can't really re-install the machine.

Comment 5 Ben Skeggs 2009-09-25 08:24:01 UTC
Have you had a change to test a later snapshot?

Comment 6 Mike Gahagan 2009-09-25 14:37:00 UTC
I'm having problems getting yesterday's USB live image to boot (using the desktop x86_64 nightly).. I'll give it a try once I can get past that or find another working live image.

Comment 7 Adam Williamson 2009-09-25 15:55:13 UTC
note that nightly builds from 20090918 to 20090923 were broken (failed to boot) but from 20090924 onwards should be OK again.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 8 Mike Gahagan 2009-09-29 13:56:58 UTC
I tested desktop-x86_64-20090927.16.iso as a USB live image using the fast user switch and vtswitch testcases, no lock-ups and no display corruption evident after switching between users/vt's for about 5 minutes. I noticed some delay initially in bringing up the login screen, but that dissapeared after the first few times so mostly likely due to slow USB I/O and the buffer cache not yet primed.

Comment 9 Adam Williamson 2009-09-29 16:55:32 UTC
Thanks.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers


Note You need to log in before you can comment on or make changes to this bug.