Bug 522659 - mouse pointer not rotated right after rotating screen
Summary: mouse pointer not rotated right after rotating screen
Keywords:
Status: CLOSED DUPLICATE of bug 522184
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-11 00:17 UTC by Michael Ploujnikov
Modified: 2009-09-17 00:41 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-17 00:41:41 UTC


Attachments (Terms of Use)
photo of the unrotated pointer right after a layout change (1.92 MB, image/jpeg)
2009-09-11 13:39 UTC, Michael Ploujnikov
no flags Details

Description Michael Ploujnikov 2009-09-11 00:17:51 UTC
Description of problem:
I noticed that after I rotate my screen on a Lenovo ThinkPad T500 laptop with Mobility Radeon HD 3650 the mouse pointer does not change orientation until it is forced to change in another way (for example by changing icon when at borders of windows)

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.13.0-0.3.20090908git651fe5a47.fc12.x86_64
kernel-2.6.31-0.219.rc9.git2.fc12.x86_64
xorg-x11-server-utils-7.4-11.fc12.x86_64
xorg-x11-drv-evdev-2.2.99-7.20090909.fc12.x86_64
xorg-x11-server-Xorg-1.6.99.900-1.fc12.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Follow the instructions on this page: https://fedoraproject.org/wiki/QA:Testcase_radeon_rotate
2. m
3.
  
Actual results:
Mouse pointer continues to point in the same direction as it did prior to the screen being rotated until it is forced to "update" by rolling over hotspots (window borders, text, links, etc).

Expected results:
Mouse pointer rotates together with the screen without any noticeable discrepancies.

Additional info:

Comment 1 Michael Ploujnikov 2009-09-11 01:10:27 UTC
I forgot to mention the test hardware profile: http://www.smolts.org/client/show/pub_b5f68d72-3548-4920-bd2f-95167f65001b

Comment 2 Michael Ploujnikov 2009-09-11 13:39:41 UTC
Created attachment 360684 [details]
photo of the unrotated pointer right after a layout change

Comment 3 Adam Williamson 2009-09-17 00:41:41 UTC

*** This bug has been marked as a duplicate of bug 522184 ***


Note You need to log in before you can comment on or make changes to this bug.