Bug 5227 - PCMCIA install fails, modprobe exits with signal 127
PCMCIA install fails, modprobe exits with signal 127
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-09-19 11:44 EDT by Hans de Goede
Modified: 2015-01-07 18:38 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-10-06 16:11:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 1999-09-19 11:44:47 EDT
PCMCIA-install (6.0.58):
pcmcia network based install fails on my toshiba T2110
notebook a 486dx75 with 12 megs of ram and 340 mb hd, it
recognises both my pcmcia controller and the pcmcia network
card, and then when cardmgr tries to modprobe pcnet_cs.o
modprobe fails on a signal 127, then some more errors and
cardmgr exits.

Here are some logs:
--- VC4 ---
Intel i82365sl B step ISA-to-PCMCIA at port 0x3e0 ofs 0x00,
2 sockets
  hosts opts [0]: none
  hosts opts [1]: none
  ISA irqs (scanned) = 3,4,5,7,9,10,11,12,15 status change
on irq 15
Sep 19 17:19:54 cardmgr[14]: starting version is 3.0.14
Sep 19 17:19:54 cardmgr[14]: watching 2 sockets
<snip ioports probe>
Sep 19 17:19:54 cardmgr[14]: fopen(stabfile) failed: No such
file or directory
Sep 19 17:19:54 cardmgr[14]: initializing socket 0
Sep 19 17:19:54 cardmgr[14]: socket 0: RPTI EP401 Ethernet
Sep 19 17:19:54 cardmgr[14]: executing 'modprobe net/8390.o'
Sep 19 17:19:54 cardmgr[14]: executing 'modprobe pcnet_cs.o'
Sep 19 17:19:54 cardmgr[14]: modprobe exited on signal 127
Sep 19 17:19:54 cardmgr[14]: get dev info on socket 0
failed: Resource temporarily unavailable
Sep 19 17:19:54 cardmgr[14]: fopen(stabfile) failed: No such
file or directory
Sep 19 17:19:54 cardmgr[14]: exiting
---

--- VC3 ---
* Flags are 0x0

* in startPcmcia()
* pcmcia probe returned; |PCI bridge probe: not found
Intel PCIC probe: i82365sl B step found, 2 sockets
|
* need to load i82365
* going to insmod pcmcia_core.o
* going to insmod i82365.o
* going to insmod ds.o
* cardmgr running as pid 14
---
Comment 1 Michael K. Johnson 1999-09-24 23:12:59 EDT
Appears to be fixed in our latest devel sources.
Comment 2 Hans de Goede 1999-09-27 18:27:59 EDT
It now indeeds get past this part.

But then it asks for a driver disk while it recognises my ne2000
pcmcia card fine, so I choose cancel.

Then I can't use ftp because I can't select a proxy and / or sername
passwd like on the networkm install disk ?

So I try using nfs instead, the mount goes ok, and I get into the
second stage install.

Only to fail with a python error when I select upgrade and it is
reading package information to upgrade.

Here's the traceback:
---
Traceback ( innermost last):
  File "/usr/bin/anaconda, line225, in ?
    intf.run(todo, test = test)
  File "/usr/lib/python1.5/site-packages/text.py", line 996 in run
    rc = apply (step[1](), step[2])
  File "/usr/lib/python1.5/site-packages/text.py", line 251 in
__call__
    todo.upgradeFindPackages (root)
  File "/usr/lib/python1.5/site-packages/todo.py", line 571, in
mountFilesystems
    os.mkdir (self.instPath + '/proc')
  OSError: [Errno 17] File exists:
    '/mnt/sysimage/proc'
Comment 3 Hans de Goede 1999-10-06 11:17:59 EDT
The second problem also appears to be solved in RedHat-6.1 final,

close please.

Note You need to log in before you can comment on or make changes to this bug.