Bug 522748 - [TAHI] DHCPv6 server Can not send relay reply message after get relay forward message
Summary: [TAHI] DHCPv6 server Can not send relay reply message after get relay forward...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: dhcp
Version: 6.1
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Jiri Popelka
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-11 10:03 UTC by Shirley Zhou
Modified: 2015-03-05 00:51 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-22 00:29:06 UTC


Attachments (Terms of Use)

Description Shirley Zhou 2009-09-11 10:03:28 UTC
Description of problem:
DHCPv6 server Can not send relay reply message after get relay forward message.

Version-Release number of selected component (if applicable):
dhcpv6-1.2.0-2.fc11.i586.rpm

How reproducible:
always

Steps to Reproduce:
1.initialize RHEL6.0 (as a DHCPv6 Server)
2.send relay forward(solicit) message to dhcpv6 server 
3.wait for relay reply (advertise) message.
You may refer to
http://focus.bne.redhat.com/~szhou/DHCP_Test/DHCPv6_Self_Test_P2_1_0_17_RHEL6.0-20090709/DHCPv6_Self_Test_P2_1_0_17_RHEL6.0-0709-server/rfc3315/S_RFC3315_7_Relay-replyMsgFormat.html
for detailed information.

Actual results:
No relay reply message.
you may check test log
at:http://focus.bne.redhat.com/~szhou/DHCP_Test/DHCPv6_Self_Test_P2_1_0_17_RHEL6.0-20090709/DHCPv6_Self_Test_P2_1_0_17_RHEL6.0-0709-server/rfc3315/12.html.

Expected results:
No relay reply message.

Additional info:
This bug does not exist in RHEl5.3 and RHEL5.4.

It prompts"dhcp6s[2216]: invalid option length in opt_44 option" in
/var/log/message/ file after this test.

Comment 2 RHEL Product and Program Management 2009-09-11 10:26:41 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 David Cantrell 2009-09-22 00:29:06 UTC
The dhcpv6 package has been obsoleted by the dhcp package.

Comment 4 Denise Dumas 2009-09-22 16:49:31 UTC
Since the dhcp package now includes ipv6 functionality on par (at least) with dhcpv6, and since we have to ship dhcp anyway, we're going to remove the dhcpv6 package from RHEL6.

Comment 5 Denise Dumas 2009-09-22 18:16:39 UTC
Because we need to remove the dhcpv6 component from bugzilla, I am moving this BZ  to component dhcp.


Note You need to log in before you can comment on or make changes to this bug.