Bug 522786 - (nouveau) When playing some ogg/theora videos in firefox, Xorg slows down and consumes 100% of one CPU core
Summary: (nouveau) When playing some ogg/theora videos in firefox, Xorg slows down and...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau
Version: rawhide
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ben Skeggs
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-11 12:51 UTC by Ivan Mironov
Modified: 2009-10-08 16:57 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-08 16:57:22 UTC


Attachments (Terms of Use)
Smolt profile (8.42 KB, text/plain)
2009-09-11 12:52 UTC, Ivan Mironov
no flags Details
Xorg log (33.40 KB, text/plain)
2009-09-11 12:52 UTC, Ivan Mironov
no flags Details
dmesg (46.80 KB, text/plain)
2009-09-11 12:53 UTC, Ivan Mironov
no flags Details

Description Ivan Mironov 2009-09-11 12:51:12 UTC
Description of problem:
I tested video output through Xv with nouveau driver as described here: https://fedoraproject.org/wiki/QA:Testcase_nouveau_xvideo. I open the following video files:
1. http://www.redhat.com/v/magazine/ogg/NET_MAN.ogg
2. http://mirrorblender.top-ix.org/peach/bigbuckbunny_movies/big_buck_bunny_480p_stereo.ogg
3. http://www.redhat.com/v/ogg/TruthHappens.ogg
with two players: Totem and Firefox (it can play ogg/theora+vorbis since version 3.5). And _only_ when playing "Truth Happens"(3) with Firefox, Xorg server is started to slow down and consume 100% of one CPU core. At this time (while firefox plays video) system is very slow to respond to input events (eg mouse clicks) and the image on entire screen is refreshed only approximately every 1-2 seconds.

Version-Release number of selected component (if applicable):
kernel-2.6.31-0.219.rc9.git2.fc12
xorg-x11-server-Xorg-1.6.99.900-1.fc12
xorg-x11-drv-nouveau-0.0.15-8.20090904git2b5ec6a.fc12
firefox-3.5.2-3.fc12
TestDay LiveCD (20090909-x86_64) without any changes.

How reproducible:
Always on my laptop, when i play "Truth Happens" with Firefox. 	
This happens only with the nouveau driver.

Steps to Reproduce:
1. Boot from TestDay LiveCD
2. Run Firefox
3. Go to this URL: http://www.redhat.com/v/ogg/TruthHappens.ogg
  
Actual results:
Xorg slows down and consumes 100% of one CPU core, video plays very slow.

Expected results:
Any video in Firefox should play smoothly.

Comment 1 Ivan Mironov 2009-09-11 12:52:11 UTC
Created attachment 360677 [details]
Smolt profile

Comment 2 Ivan Mironov 2009-09-11 12:52:41 UTC
Created attachment 360678 [details]
Xorg log

Comment 3 Ivan Mironov 2009-09-11 12:53:01 UTC
Created attachment 360679 [details]
dmesg

Comment 4 Adam Williamson 2009-09-17 20:38:06 UTC
I can reproduce this on my system, actually. Exact same symptom. Doesn't happen playing the video in Totem. Mine's a GeForce 9400, so not identical hardware. Not sure if this is a nouveau or firefox bug, though (what does firefox even use to do its video playback?)

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 5 Ben Skeggs 2009-10-08 04:19:52 UTC
Can no longer reproduce this issue with the following packages, there's been a couple of minor performance fixes in the nouveau ddx that could've been responsible.  Can either of you confirm?

libdrm-2.4.14-1.fc12
xorg-x11-server-Xorg-1.6.99.903-2.fc12
xorg-x11-drv-nouveau-0.0.15-13.20090929gitdd8339f.fc12
kernel-2.6.31.1-56.fc12

Comment 6 Adam Williamson 2009-10-08 16:57:22 UTC
confirmed here - can no longer reproduce. closing. ivan, re-open if you still have trouble. thanks!

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers


Note You need to log in before you can comment on or make changes to this bug.