Bug 522832 - search box doesn
Summary: search box doesn
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-11 17:24 UTC by Matthias Clasen
Modified: 2018-04-11 09:05 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-06 08:48:47 UTC


Attachments (Terms of Use)

Description Matthias Clasen 2009-09-11 17:24:57 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Matthias Clasen 2009-09-11 17:25:44 UTC
I normally always go to google manually. Today I tried to use the search box, and was greeted with an awe assertion popup:

ASSERT: *** Search: _installLocation: engine has no file!
Stack Trace: 
0:ENSURE_WARN(false,_installLocation: engine has no file!,2147500037)
1:()
2:()
3:SRCH_ENG_getSubmission(icccm,text/html)
4:getSubmission(icccm,null)
5:doSearch(icccm,current)
6:handleSearchCommand([object KeyboardEvent])
7:onTextEntered()
8:handleEnter(false)
9:onKeyPress([object KeyboardEvent])
10:onxblkeypress([object KeyboardEvent])

~

Comment 2 Matěj Cepl 2009-10-05 18:01:42 UTC
I guess we have a profile corruption. Could I get output of

rpm -qf /usr/lib*/firefox-*/searchplugins/google.xml
rpm -Vf /usr/lib*/firefox-*/searchplugins/google.xml

(to be sure, installation itself is OK), please?

Alternatively, if you don't have any extra plugins installed, you can click on the icon with search engine symbol and in "Manage Search Engines" click on "Restore Defaults".

Does it help?

Thanks

Comment 3 Matthias Clasen 2009-10-06 01:46:29 UTC
Naturally, I can't reproduce this anymore. Search box works just fine here now.

Comment 4 Matěj Cepl 2009-10-06 08:48:47 UTC
OK, sorry, that I don't see anything else to do.


Note You need to log in before you can comment on or make changes to this bug.