Bug 522943 - Fast User Switching Results in Blank Login Screen
Fast User Switching Results in Blank Login Screen
Status: CLOSED DUPLICATE of bug 512944
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-12 10:20 EDT by CAI Qian
Modified: 2015-01-14 18:23 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-21 13:35:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Smolt Profile (6.59 KB, text/plain)
2009-09-12 10:20 EDT, CAI Qian
no flags Details
dmesg -- nomodeset (34.23 KB, text/plain)
2009-09-12 10:21 EDT, CAI Qian
no flags Details
Xorg.0.log -- nomodeset (49.74 KB, text/plain)
2009-09-12 10:21 EDT, CAI Qian
no flags Details

  None (edit)
Description CAI Qian 2009-09-12 10:20:54 EDT
Created attachment 360782 [details]
Smolt Profile

Description of problem:
Sometimes, fast user switching results in blank login screen. There is no user list, no login/cancel icons. It is just an empty grey box there, and the mouse pointer seems loading forever. If choose to suspend from the Power icon at the bottom right, it can recover. This is without KMS.

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.12.2-19.fc12.x86_64
gdm-user-switch-applet-2.27.90-2.fc12.x86_64
kernel-2.6.31-2.fc12.x86_64

How reproducible:
usually

Steps to Reproduce:
1. Ensure the 'nomodeset' in your bootloader configuration (need it for basic
   X operation to suceed).
2. Ensure the file /etc/X11/xorg.conf does not exist, or is a known-good
   configuration file that uses the 'radeon' driver
3. Shut your system down entirely, then start it up again
4. Create a second regular user account, if you do not already have one
   available
5. Trigger fast switching (in a default Fedora desktop, click your name at
   the top right hand corner, then select Switch User) 

Actual results:
Blank Login screen.

Expected results:
Login screen with user list and usual buttons.
Comment 1 CAI Qian 2009-09-12 10:21:24 EDT
Created attachment 360783 [details]
dmesg -- nomodeset
Comment 2 CAI Qian 2009-09-12 10:21:48 EDT
Created attachment 360784 [details]
Xorg.0.log -- nomodeset
Comment 3 CAI Qian 2009-09-12 10:36:12 EDT
Looks like the login screen is GDM. Here is the version,

gdm-2.27.90-2.fc12.x86_64
Comment 4 CAI Qian 2009-09-16 01:26:16 EDT
This might not be a driver specific problem, since it happens for another machine with Intel card.
Comment 5 Adam Williamson 2009-10-21 13:35:33 EDT
we've been investigating this in the blocker bug review meeting this morning. it seems there are many reports of this type across multiple types of video hardware. closing all reports as dupes of 512944, which is the earliest report. 512944 will be marked as a release blocker.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 512944 ***

Note You need to log in before you can comment on or make changes to this bug.