Bug 522948 - Using Pxe/Cobbler for Fedora 12 Alpha, network can't be loaded
Summary: Using Pxe/Cobbler for Fedora 12 Alpha, network can't be loaded
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: mkinitrd
Version: 12
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-12 15:26 UTC by Michael Breuer
Modified: 2010-01-12 15:32 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-01-12 15:32:22 UTC
Type: ---


Attachments (Terms of Use)

Description Michael Breuer 2009-09-12 15:26:29 UTC
Description of problem:

Tried to do a network install to an old laptop. Using Fedora 12 Alpha, the initrd bundled with the distro (after a cobbler import) cannot start the network.

Imported Fedora 11 using the same steps and the network installation proceeds correctly.

There were some notes in the change log about new network manager behaviour,  methinks it broke the ability to pxe install Fedora.

Not sure of the version of the supplied initrd - mkinitrd is

mkinitrd-6.0.92-2.fc12

MD5 of the initrd downloaded is e2bdd33caab9868192f730bbfe7b9f6b

Main point - F11 works, F12 does not - same config, same hardware.

Comment 1 Michael Breuer 2009-09-12 22:22:37 UTC
Just an FYI... doesn't boot with the ISO disk (dvd) either. Still looking into that. F11 iso does boot.

Comment 2 Michael Breuer 2009-09-12 23:12:01 UTC
And one more update... (again, not sure this bug is filed correctly at this point)... 

The only way I can get anywhere on this f12 Alpha install (dvd iso) is with the noprobe option. Any other set of options (and I've tried them all) gets a frozen system with either a blue screen, or corrupted screen. 

Noprobe gets me to the language selection screen, followed by a notice that no drives were found would I like to select more hardware... then back to keyboard language, then to a console:

loader received SIGSEGV! Backtrace:
/sbin/loader[0x804e071]
[0x989400]
/sbin/loader[0x804f6b1]
/ilb/libc.so.6(__libc_start_main+0xe6)[0x54db36]
/sbin/loader[0x804be21]
install exited abnoramlly [1/1]
you may safely reboot your system
--
poking around the other console pages for things that may be useful...

kernel command line: initrd=initrd.img stage2=hd:LABEL=Fedora expert noprobe text BOOT_IMAGE=vmlinux

[expert didn't matter... nor did text... noprobe got me this far]

...
starting STEP_STAGE2
partition is LABEL=Fedora, dir is (null)
missing partition or directory specification
no devices found to load drivers from
53 keymaps are available

---
No iBFT detected.
...
Network manager stuff:

ifcfg-rh: Could not get hostname: failed to read /etc/sysconfig/network
Loaded plugin ifcfg-rh...
Wireless now enabled by radio killswitch
....
bunch of wireless and supplicant messages... interesting as this laptop does not have built-in wireless and I pulled the pcmcia card out before booting (I get the same messages with the card inserted)

---
That's it for now... happy to dig deeper but not sure where to go next.

Comment 3 Bug Zapper 2009-11-16 12:18:41 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 4 Hans de Goede 2010-01-12 15:32:22 UTC
This is a mass edit of all mkinitrd bugs.

Thanks for taking the time to file this bug report (and/or commenting on it).

As you may have heard in Fedora 12 mkinitrd has been replaced by dracut. In Fedora 12 the mkinitrd package is still around as some programs depend on
certain libraries it provides, but mkinitrd itself is no longer used.

In Fedora 13 mkinitrd will be removed completely. This means that all work
on initrd has stopped.

Rather then keeping mkinitrd bugs open and giving false hope they might get fixed we are mass closing them, so as to clearly communicate that no more work will be done on mkinitrd. We apologize for any inconvenience this may cause. 

If you are using Fedora 11 and are experiencing a mkinitrd bug you cannot work around, please upgrade to Fedora 12. If you experience problems with the initrd in Fedora 12, please file a bug against dracut.


Note You need to log in before you can comment on or make changes to this bug.