Bug 52296 - patch cannot handle a file without a newline
patch cannot handle a file without a newline
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: diffutils (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-22 12:09 EDT by hjl
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-22 12:09:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A testcase (490 bytes, patch)
2001-08-22 12:09 EDT, hjl
no flags Details | Diff

  None (edit)
Description hjl 2001-08-22 12:09:08 EDT
# make
diff -up old new > diff || :
patch -p0 old -o patched < diff
patching file old
Hunk #1 FAILED at 6.
1 out of 1 hunk FAILED -- saving rejects to file patched.rej
make: *** [patch] Error 1
Comment 1 hjl 2001-08-22 12:09:40 EDT
Created attachment 28934 [details]
A testcase
Comment 2 Tim Waugh 2001-08-22 12:22:12 EDT
[tim@cyberelk patch]$ make
diff -up old new > diff || :
patch -p0 old -o patched < diff
patching file old
[tim@cyberelk patch]$ rpm -q patch
patch-2.5.4-10
[tim@cyberelk tim]$ rpm -q diffutils
diffutils-2.7.2-2

I guess this was fixed in diffutils 2.7.2, since the patch changes are minimal.
Comment 3 hjl 2001-08-22 12:27:24 EDT
diffutils-2.7.2-2 does make a difference.

Note You need to log in before you can comment on or make changes to this bug.