Bug 522987 - [Playstation 3] non-English installation fails (anaconda crashes)
Summary: [Playstation 3] non-English installation fails (anaconda crashes)
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-date
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-13 01:50 UTC by Frederik Hertzum
Modified: 2010-06-12 12:46 UTC (History)
8 users (show)

Fixed In Version: Fedora 13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-12 12:45:35 UTC
frederik.hertzum: fedora_requires_release_note+


Attachments (Terms of Use)

Description Frederik Hertzum 2009-09-13 01:50:26 UTC
Description of problem:
Using both 32 and 64 bit kernels, it is not possible to boot the install DVD for PowerPC on a Playstation 3. 64 bit kernels hang and 32 bit kernels make the machine shut down with no apparent warning.

Version-Release number of selected component (if applicable):
Fedora 12 Alpha

How reproducible:
Always

Steps to Reproduce:
1. Install kboot on a Playstation 3
2. Boot otheros on the Playstation with a Fedora 12 Alpha DVD in the drive
3. Select either kernel to boot
  
Actual results:
64 bit kernels hang (I waited 10 minutes with no change), 32 bit kernels shut down the machine.

Expected results:
Kernel is loaded and executed, resulting in Anaconda starting up and the install process beginning.

Additional info:
System software version on my machine is 3.0.

Comment 1 Vedran Miletić 2009-10-26 11:22:16 UTC
Is Fedora 12 beta any better?

Comment 2 Bug Zapper 2009-11-16 12:19:40 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 3 niowfi 2009-11-25 09:10:01 UTC
I have the same problem with the final release.

Comment 4 Frederik Hertzum 2009-11-25 12:04:39 UTC
With Fedora 12 release I have the 64 bit kernel booting fine on a PS3 but with the installer always failing (disc and image has been verified to be good). The 32 bit kernel still dies right away.

System software is now 3.1.

Comment 5 Frederik Hertzum 2009-11-25 12:05:41 UTC
Once I get home (@work atm) I'll try to get a copy of the error report I get from the installer -- it might shed some light on what's wrong.

Comment 6 niowfi 2009-11-25 23:12:14 UTC
Ha... It work today. I installed Fedora 12 on my Ps3

What different since last week ?

Last week when I tried to install Fedora 12, Ubuntu was installed on my PS3.

This week, I bought a new hard disk for my ps3 (500gb) to remplace my 40 gb.
I restored my ps3 data on my primary partition and I installed Fedora 12 on my other new formated partition (10gb). 

Maybe last week my fedora 12 installation failed because a other linux was installed ? I think I had the same error than you Frederik.

Comment 7 niowfi 2009-11-26 00:23:25 UTC
After my fedora 12 installation, I tried to reinstall it again.

I found what wrong last week. It's because I tried to install fedora in  french. When I try to install in English it install without error.

If I choose "French" on the Language Selection screen, I got this error after the "Finding storage device". 


anaconda 12.46 exception report
Traceback (most recent call first):
  File
"/usr/lib/python2.6/site-packages/scdate/core/zonetab.py", line 81, in <lamba>
	translated = reduce(lamba x, y: x.replace(y, "/"),
  File
"/usr/lib/python2.6/site-packages/scdate/core/zonetab.py", line 83, in__translate_tz translated}
  File
"/usr/lib/python2.6/site-packages/scdate/core/zonetab.py", line 105, in_set_tz self.__translate.tz()
  File
"/usr/lib/python2.6/site-packages/scdate/core/zonetab.py", line 51, in__init__set_tz = tz.replace ('_',' ')
  File
"/usr/lib/python2.6/site-packages/scdate/core/zonetab.py", line 196, in readZoneTab entry = ZoneTabEntry (code, lat, long, tz, comments)
  File
"/usr/lib/python2.6/site-packages/scdate/core/zonetab.py", line 131, in __init__ self.readZoneTab (fn)
  File
"/usr/lib/anaconda/textw/timezone_text.py", line 39, in getTimezoneList zt = zonetab.ZoneTab()
  File
"/usr/lib/anaconda/textw/timezone_text.py", line 67, in __call__ timezones = self.getTimezoneList()
File "/usr/lib/anaconda/textw/timezone_text.py", line 408, in run
	rc = win(self.screen, instance)
File "usr/bin/anaconda", line 968, in <module>
	anaconda.intf.run(anaconda)UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 2: ordinal not in range(128)

Comment 8 Frederik Hertzum 2009-11-26 19:26:22 UTC
I can confirm (at least to the extent that the experience of two people is a confirmation) that not picking english as the main language is the problem -- I was using danish when it failed, but using the same install configuration, except with english as the language, it works fine (for now -- still installing).

This should properbly be in the release notes.

I no-one minds, I'm going to close this one.

Comment 9 Vedran Miletić 2009-11-27 07:43:47 UTC
No, please leave it open in hope to get it fixed for Fedora 13 or some kind of Fedora 12 ReSpin (if it happens).

Comment 10 Radek Vykydal 2009-11-27 10:54:24 UTC
I reproduced the bug on i386 in virtual machine with F12. By choosing non-english language it reproducible in text mode install.

Comment 11 Frederik Hertzum 2009-11-27 17:08:33 UTC
(In reply to comment #9)
> No, please leave it open in hope to get it fixed for Fedora 13 or some kind of
> Fedora 12 ReSpin (if it happens).  

Seeing that the problem exists outside of PS3 land I agree. Leaving it open.
I still think it needs to be in the release notes untill a fixed spin has been released (respin of Fedora 12 or Fedora 12 + n).

Comment 12 Frederik Hertzum 2010-05-31 03:08:09 UTC
I have not seen this on F13 x86_64 so I will close this bug if no-one objects.


Note You need to log in before you can comment on or make changes to this bug.