Bug 523043 - setroubleshoot: SELinux is preventing the wineserver from using potentially mislabeled files (reg125f0000.tmp).
Summary: setroubleshoot: SELinux is preventing the wineserver from using potentia...
Keywords:
Status: CLOSED DUPLICATE of bug 523042
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:23e2c9ff579...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-13 16:23 UTC by Antonio A. Olivares
Modified: 2009-09-14 16:34 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-14 16:34:59 UTC


Attachments (Terms of Use)

Description Antonio A. Olivares 2009-09-13 16:23:00 UTC
The following was filed automatically by setroubleshoot:

Summary:

SELinux is preventing the wineserver from using potentially mislabeled files
(reg125f0000.tmp).

Detailed Description:

[wineserver has a permissive type (wine_t). This access was not denied.]

SELinux has denied wineserver access to potentially mislabeled file(s)
(reg125f0000.tmp). This means that SELinux will not allow wineserver to use
these files. It is common for users to edit files in their home directory or tmp
directories and then move (mv) them to system directories. The problem is that
the files end up with the wrong file context which confined applications are not
allowed to access.

Allowing Access:

If you want wineserver to access this files, you need to relabel them using
restorecon -v 'reg125f0000.tmp'. You might want to relabel the entire directory
using restorecon -R -v 'reg125f0000.tmp'.

Additional Information:

Source Context                unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:user_home_t:s0
Target Objects                reg125f0000.tmp [ dir ]
Source                        wineserver
Source Path                   /usr/bin/wineserver
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           wine-core-1.1.26-1.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.28-5.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   home_tmp_bad_labels
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.31-0.162.rc6.git2.fc12.i686 #1 SMP Mon Aug 17
                              16:22:01 EDT 2009 i686 i686
Alert Count                   6
First Seen                    Mon 24 Aug 2009 12:01:04 PM CDT
Last Seen                     Mon 24 Aug 2009 12:01:34 PM CDT
Local ID                      2f8b759f-3ac4-4176-8947-bbf4b39986db
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1251133294.37:197): avc:  denied  { remove_name } for  pid=4703 comm="wineserver" name="reg125f0000.tmp" dev=dm-0 ino=143524 scontext=unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=dir

node=(removed) type=AVC msg=audit(1251133294.37:197): avc:  denied  { rename } for  pid=4703 comm="wineserver" name="reg125f0000.tmp" dev=dm-0 ino=143524 scontext=unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1251133294.37:197): avc:  denied  { unlink } for  pid=4703 comm="wineserver" name="system.reg" dev=dm-0 ino=143520 scontext=unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1251133294.37:197): arch=40000003 syscall=38 success=yes exit=0 a0=8d5f940 a1=808fc90 a2=8beec40 a3=8d5f940 items=0 ppid=1 pid=4703 auid=500 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=1 comm="wineserver" exe="/usr/bin/wineserver" subj=unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023 key=(null)


audit2allow suggests:

#============= wine_t ==============
allow wine_t user_home_t:dir remove_name;
allow wine_t user_home_t:file { rename unlink };

Comment 1 Daniel Walsh 2009-09-14 16:34:59 UTC

*** This bug has been marked as a duplicate of bug 523042 ***


Note You need to log in before you can comment on or make changes to this bug.