Bug 523047 - setroubleshoot: SELinux is preventing /usr/bin/pulseaudio "setrlimit" access.
Summary: setroubleshoot: SELinux is preventing /usr/bin/pulseaudio "setrlimit" access.
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:557f910f76a...
: 523048 523049 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-13 17:18 UTC by Horst H. von Brand
Modified: 2009-09-14 16:46 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-14 16:44:51 UTC


Attachments (Terms of Use)

Description Horst H. von Brand 2009-09-13 17:18:43 UTC
The following was filed automatically by setroubleshoot:

Summary:

SELinux is preventing /usr/bin/pulseaudio "setrlimit" access.

Detailed Description:

SELinux denied access requested by pulseaudio. It is not expected that this
access is required by pulseaudio and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                unconfined_u:unconfined_r:nsplugin_t:s0-s0:c0.c102
                              3
Target Context                unconfined_u:unconfined_r:nsplugin_t:s0-s0:c0.c102
                              3
Target Objects                None [ process ]
Source                        pulseaudio
Source Path                   /usr/bin/pulseaudio
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           pulseaudio-0.9.17-1.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.31-3.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.31-2.fc12.x86_64
                              #1 SMP Thu Sep 10 00:25:40 EDT 2009 x86_64 x86_64
Alert Count                   16
First Seen                    Sun 13 Sep 2009 01:17:14 PM CLT
Last Seen                     Sun 13 Sep 2009 01:17:14 PM CLT
Local ID                      d298b0bc-973a-41e2-a046-695e9a0db4fb
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1252862234.638:277): avc:  denied  { setrlimit } for  pid=18636 comm="pulseaudio" scontext=unconfined_u:unconfined_r:nsplugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:nsplugin_t:s0-s0:c0.c1023 tclass=process

node=(removed) type=SYSCALL msg=audit(1252862234.638:277): arch=c000003e syscall=160 success=no exit=-13 a0=f a1=7fff4196c000 a2=40e67e a3=1 items=0 ppid=18631 pid=18636 auid=500 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=17 comm="pulseaudio" exe="/usr/bin/pulseaudio" subj=unconfined_u:unconfined_r:nsplugin_t:s0-s0:c0.c1023 key=(null)


audit2allow suggests:

#============= nsplugin_t ==============
allow nsplugin_t self:process setrlimit;

Comment 1 Daniel Walsh 2009-09-14 16:44:51 UTC
Fixed in selinux-policy-3.6.31-4.fc12.noarch

Comment 2 Daniel Walsh 2009-09-14 16:45:52 UTC
*** Bug 523048 has been marked as a duplicate of this bug. ***

Comment 3 Daniel Walsh 2009-09-14 16:46:11 UTC
*** Bug 523049 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.