Bug 52308 - attempting to make php 4.0.6 using gcc-2.96
Summary: attempting to make php 4.0.6 using gcc-2.96
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-22 17:23 UTC by Daniel Rincon
Modified: 2007-04-18 16:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-22 18:58:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the configuration options i am using to build the php (290 bytes, patch)
2001-08-22 17:25 UTC, Daniel Rincon
no flags Details | Diff
the .i file from the zend_compile.c function (217.82 KB, application/octet-stream)
2001-08-22 18:55 UTC, Daniel Rincon
no flags Details

Description Daniel Rincon 2001-08-22 17:23:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.2-2 i586)

Description of problem:
set the options that i wanted to use and type in make 
i recieve the following errors

zend_ini_parser.c: In function `ini_error':
zend_ini_parser.c:162: Internal error: Segmentation fault.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[1]: *** [zend_ini_parser.lo] Error 1
make[1]: Leaving directory `/usr/local/src/php-4.0.6/Zend'
make: *** [all-recursive] Error 1

type in make again and it continues 
zend_operators.c: In function `convert_to_object':
zend_operators.c:541: Internal error: Segmentation fault.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[1]: *** [zend_operators.lo] Error 1
make[1]: Leaving directory `/usr/local/src/php-4.0.6/Zend'
make: *** [all-recursive] Error 1

if i continue to make eventually it will cease to make when compiling imap
functions

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. download php-4.0.6 
2. configure 
3. make 
	

Actual Results:  it compiles for a time then comes up with the errors that
i described above 


Expected Results:  no erros , a sucessful build

Additional info:

computer configuration 
amd k6 500 512 mb ram , running kernel version 2.4.2

Comment 1 Daniel Rincon 2001-08-22 17:25:19 UTC
Created attachment 28954 [details]
the configuration options i am using to build the php

Comment 2 Jakub Jelinek 2001-08-22 17:44:52 UTC
Is it reproduceable?
If yes, can you please attach zend_ini_parser.i (use -save-temps option
in addition to other options make is passing to gcc when compiling
this file).

Comment 3 Daniel Rincon 2001-08-22 18:55:54 UTC
Created attachment 28995 [details]
the .i file from the zend_compile.c function

Comment 4 Daniel Rincon 2001-08-22 18:56:52 UTC
the "bug" is not reproducable 
the compiler seg faults at various places 


Comment 5 Daniel Rincon 2001-08-22 18:58:53 UTC
here are the additional flags being passed on to the compiler 
gcc -DHAVE_CONFIG_H -I. -I. -I../main   -DLINUX=22 -DMOD_SSL=208101 -DEAPI
-DEAPI_MM -DUSE_EXPAT -DDMALLOC_FUNC_CHECK -DSUPPORT_UTF8 -DXML_BYTE_ORDER=12
-save-temps  -g -O2 -c

Comment 6 Jakub Jelinek 2001-08-28 11:24:38 UTC
If it is not reproduceable (and I could not reproduce it using the source
you provided), then it in 99.999% of cases means you have flakey hardware,
be it RAM, CPU or board.


Note You need to log in before you can comment on or make changes to this bug.