Bug 523084 - Akregator Cannot Handle Secure RSS Feeds
Summary: Akregator Cannot Handle Secure RSS Feeds
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: kdepim
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Than Ngo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-13 23:36 UTC by David Le Sage
Modified: 2010-02-15 19:15 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-15 19:11:42 UTC
Type: ---


Attachments (Terms of Use)

Description David Le Sage 2009-09-13 23:36:03 UTC
Description of problem:
Not sure if this is a bug or a limitation of the software... If an RSS feed requires a password, Akregator is simply failing to retrieve the articles.  It neither prompts the user for a password nor does it display any error message if the OPML is imported.  If the secure feed is added from scratch, an incorrect "feed not found" message is diplayed.

Version-Release number of selected component (if applicable):
Akregator 1.5.0 (KDE 4.3.0)

How reproducible:
Every time.

Steps to Reproduce:
1. yum install kdepim.
2. Launch akregator.
3. Import an *.opml file containing a feed that requires a password.
4. Try to fetch feed.  User is neither prompted for the password nor confronted with an error message.
5. We now try to add the feed afresh:  Feed->Add Feed.
6. Input

https://jira.jboss.org/jira/sr/jira.issueviews:searchrequest-comments-rss/12312796/SearchRequest-12312796.xml?tempMax=25

as the feed name.
7. "Feed not found" error dialogue box appears, despite the fact that the feed exists and antoehr RSS feeder (Blam) can retrieve the articles.
  
Actual results:
Cannot detect this feed nor retrieve the article

Expected results:
Should either prompt user for a password and then retrieve the articles or, in both situations, display a correct error message that it cannot retrieve articles from secure feeds.

Additional info:

Comment 1 Ryan McCoskrie 2009-09-20 20:52:35 UTC
Hmm. Have you reported this to the KDE team?

It sounds like the sort of problem that should
be addressed in the next version of Akregator.

Comment 2 Steven M. Parrish 2009-10-02 08:58:21 UTC
Thank you for taking the time to report this issue.

This is an issue that needs to be addressed by the upstream developers. Please report this at http://bugs.kde.org and then add the upstream report information to this report.  We will monitor the upstream report for a resolution to this issue, and will review any bug fixes that become available for consideration in future updates.

Setting status to NEEDINFO, and awaiting upstream bug report URL for tracking.

Thanks in advance.

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 3 David Le Sage 2009-10-04 23:35:04 UTC
Added to KDE Bugzilla as:


https://bugs.kde.org/show_bug.cgi?id=209472


Cheers,

David Le Sage
Red Hat
BRISBANE

Comment 4 Rex Dieter 2010-02-15 19:11:42 UTC
Thanks, we'll continue to track this upstream.

Comment 5 Rex Dieter 2010-02-15 19:15:01 UTC
Fwiw, (as mentioned in the upstream report), I am not able to reproduce this using akreagator-1.6 from kde sc 4.4.0


Note You need to log in before you can comment on or make changes to this bug.