Bug 52312 - AMI 1600 driver hangs system on second load attempt
Summary: AMI 1600 driver hangs system on second load attempt
Status: CLOSED DUPLICATE of bug 45207
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: ia64 Linux
high
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-22 17:45 UTC by Matthew Tolentino
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-22 17:46:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matthew Tolentino 2001-08-22 17:45:57 UTC
Description of Problem:
AMI 1600 megaraid driver causes a system hang when loaded twice.

Version-Release number of selected component (if applicable):
megaraid driver v1.17a

How Reproducible:
Always


Steps to Reproduce:
1. insmod megaraid driver
2. rmmod megaraid
3. insmod megaraid
4. <hang>


Actual Results:
System hang

Expected Results:
driver should load and unload repeatedly and should not hang system. 
Problem seen with version v1.15a of megaraid driver, not seen with v1.15d 
of driver.  Has reappeared with version v.17a of driver. 


Additional Information:
Problem seen with version v1.15a of megaraid driver, not seen with v1.15d 
of driver.  Has reappeared with version v.17a of driver. 

Note: System hang occurs on second load of driver with >4GB system 
memory.  Will eventually fail with <4GB system memory if put into 
load/unload loop.

while true; do; insmod megaraid; wait; rmod megaraid; wait; done;

Comment 1 Bill Nottingham 2001-08-23 02:46:51 UTC

*** This bug has been marked as a duplicate of 45207 ***


Note You need to log in before you can comment on or make changes to this bug.