Bug 523176 - setroubleshoot: SELinux is preventing the /bin/loadkeys from using potentially mislabeled files (Documents).
Summary: setroubleshoot: SELinux is preventing the /bin/loadkeys from using poten...
Keywords:
Status: CLOSED DUPLICATE of bug 523175
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:79d942e7a7d...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-14 11:43 UTC by andreasfrische+redhat
Modified: 2009-09-19 19:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-19 19:40:32 UTC


Attachments (Terms of Use)

Description andreasfrische+redhat 2009-09-14 11:43:04 UTC
The following was filed automatically by setroubleshoot:

Summary:

SELinux is preventing the /bin/loadkeys from using potentially mislabeled files
(Documents).

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux has denied loadkeys access to potentially mislabeled file(s)
(Documents). This means that SELinux will not allow loadkeys to use these files.
It is common for users to edit files in their home directory or tmp directories
and then move (mv) them to system directories. The problem is that the files end
up with the wrong file context which confined applications are not allowed to
access.

Allowing Access:

If you want loadkeys to access this files, you need to relabel them using
restorecon -v 'Documents'. You might want to relabel the entire directory using
restorecon -R -v 'Documents'.

Additional Information:

Source Context                unconfined_u:unconfined_r:loadkeys_t:s0-s0:c0.c102
                              3
Target Context                unconfined_u:object_r:user_home_t:s0
Target Objects                Documents [ dir ]
Source                        loadkeys
Source Path                   /bin/loadkeys
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           kbd-1.15-9.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.31-2.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Permissive
Plugin Name                   home_tmp_bad_labels
Host Name                     (removed)
Platform                      Linux (removed) 2.6.31-2.fc12.x86_64
                              #1 SMP Thu Sep 10 00:25:40 EDT 2009 x86_64 x86_64
Alert Count                   2
First Seen                    Mon 14 Sep 2009 01:39:11 PM EDT
Last Seen                     Mon 14 Sep 2009 01:39:11 PM EDT
Local ID                      4506efee-49a7-4a59-a563-ed3691023a7b
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1252949951.784:43): avc:  denied  { read } for  pid=2266 comm="loadkeys" name="Documents" dev=dm-0 ino=82007 scontext=unconfined_u:unconfined_r:loadkeys_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=dir

node=(removed) type=AVC msg=audit(1252949951.784:43): avc:  denied  { open } for  pid=2266 comm="loadkeys" name="Documents" dev=dm-0 ino=82007 scontext=unconfined_u:unconfined_r:loadkeys_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1252949951.784:43): arch=c000003e syscall=2 success=yes exit=0 a0=40f417 a1=90800 a2=1 a3=7fffe1945520 items=0 ppid=2131 pid=2266 auid=500 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=1 comm="loadkeys" exe="/bin/loadkeys" subj=unconfined_u:unconfined_r:loadkeys_t:s0-s0:c0.c1023 key=(null)


audit2allow suggests:

#============= loadkeys_t ==============
allow loadkeys_t user_home_t:dir { read open };

Comment 1 andreasfrische+redhat 2009-09-19 19:40:32 UTC

*** This bug has been marked as a duplicate of bug 523175 ***


Note You need to log in before you can comment on or make changes to this bug.