Bug 523204 - Compiz fails on alt+tab
Summary: Compiz fails on alt+tab
Keywords:
Status: CLOSED DUPLICATE of bug 522312
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 523708 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-14 13:30 UTC by Luinnar
Modified: 2009-09-21 15:56 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-21 15:56:38 UTC


Attachments (Terms of Use)

Description Luinnar 2009-09-14 13:30:54 UTC
Description of problem:
The LiveCD distribution testday-20090909-x86_64.iso has problems with compiz software on my PC with Radeon HD 3200. When compiz is enabled, push alt+tab - title bars will disappear in all running programs and keyboard will stop working, however mouse will continue to work fine.


Version-Release number of selected component (if applicable):
LiveCD distribution testday-20090909-x86_64.iso.


How reproducible:
Steps to Reproduce:
Try to perform the test "QA:Testcase radeon glx" from the following web page:
http://fedoraproject.org/wiki/QA:Testcase_radeon_glx

Actual results:
When compiz is enabled, push alt+tab - title bars will disappear in all running programs and keyboard will stop working, however mouse will continue to work fine.

Expected results:
Keyboard should work correctly, program title bars should be visible.

Additional info:
Motherboard: Asus M3A-H/HDMI
Video: ATI Radeon HD3200 GPU (Integrated).

Comment 1 Adam Williamson 2009-09-17 00:57:32 UTC
can you possibly run compiz from a terminal (rather than enabling it from the desktop-effects thingy) and see whether you get a useful crash message at the terminal when you reproduce the bug?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 2 Robert Laverick 2009-09-18 16:58:44 UTC
I can confirm seeing this problem as well.  It was also noted by Dariusz Garbowski in his notes on the test day, but doesn't seem to have been entered as a bug other than here that I can see.

Smolt: http://www.smolts.org/client/show/pub_3885987d-0be7-4cd3-9acf-adb1786960aa

Version: rawhide up to date as of 18th Sept

I didn't know how to start compiz from commandline however starting the desktop effects switcher from the command line gives as follows.

[robert@hard-core ~]$ desktop-effects 
IRQ's not enabled, falling back to busy waits: 2 1
IRQ's not enabled, falling back to busy waits: 2 1
IRQ's not enabled, falling back to busy waits: 2 1
gtk-window-decorator: Screen 0 on display ":0.0" already has a decoration manager; try using the --replace option to replace the current decoration manager.
IRQ's not enabled, falling back to busy waits: 2 1
compiz (video) - Warn: No 8 bit GLX pixmap format, disabling YV12 image format
Cannot register the panel shell: there is already one running.
compiz: radeon_cs_gem.c:121: cs_gem_write_reloc: Assertion `bo->space_accounted' failed.
Cannot register the panel shell: there is already one running.
[robert@hard-core ~]$ 

The when alt+tabing the error is compiz:radeon_cs_gem.c:121

Comment 3 Robert Laverick 2009-09-18 17:21:19 UTC
I think I've submitted a decented backtrace on this now, tho I didn't know what I was doing with the auto bug report tool, so it's a bit of a mess, it's in case 523708

Comment 4 Adam Williamson 2009-09-18 18:52:44 UTC
*** Bug 523708 has been marked as a duplicate of this bug. ***

Comment 5 Adam Williamson 2009-09-18 18:53:29 UTC
Thanks. maintainer, please see 523708 for trace.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 6 Luinnar 2009-09-21 07:46:17 UTC
Here is the output of compiz:
------------------------------
liveuser@localhost ~]$ compiz --ignore-desktop-hints --always-swap glib gconf gnomecompat --replace
IRQ's not enabled, falling back to busy waits: 2 1
compiz (video) - Warn: No 8 bit GLX pixmap format, disabling YV12 image format
compiz: radeon_cs_gem.c:121: cs_gem_write_reloc: Assertion `bo->space_accounted' failed.
Aborted (core dumped)
------------------------------

Comment 7 Luinnar 2009-09-21 07:49:40 UTC
PS: The assertion above fails on alt+tab and also when user tries to see the bottom side of the desktop cube.

Comment 8 Robert Laverick 2009-09-21 07:57:43 UTC
(In reply to comment #7)
assuming this is the same problem then bug 522312 is a dupe, tho I guess it depends on if it's that line or some per-condition that is different.

Comment 9 Adam Williamson 2009-09-21 15:56:38 UTC
yes, looks like the same problem.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 522312 ***


Note You need to log in before you can comment on or make changes to this bug.