Bug 523216 - Activating Satellite 5.3 fails with <Fault -2: 'unhandled internal exception: The string asciiSig is not a valid signature'>
Summary: Activating Satellite 5.3 fails with <Fault -2: 'unhandled internal exception:...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Other
Version: RHN Stable
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: rhn-dev-list
QA Contact: Red Hat Network Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-14 13:56 UTC by Jan Pazdziora
Modified: 2012-02-20 09:30 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-02-20 09:30:31 UTC


Attachments (Terms of Use)

Description Jan Pazdziora 2009-09-14 13:56:35 UTC
Description of problem:

I have Satellite 5.3, one on RHEL 4 and one on RHEL 5. I run the installation and gave it certificate

http://svn.rhndev.redhat.com/viewcvs/*checkout*/trunk/pm/satellite-certs/satellite-5.3/redhat-internal-devel.cert?rev=187008

It activated locally fine and then installation failed with error

<Fault -2: 'unhandled internal exception: The string asciiSig is not a valid signature'>

Repeated attempts of running rhn-satellite-activate show the same error.

I was then able to paste the certificate and activate the Satellite on hosted's WebUI just fine. The profiles are 1015742537 and 1015742543.

Version-Release number of selected component (if applicable):

Hosted as of today (5.1.2), Satellite 5.3 certificate rev. 187008.

How reproducible:

Deterministic both from RHEL 4 and from RHEL 5 Satellite.

Steps to Reproduce:
1. Run Satellite 5.3 installer.
2. Give it the above referenced certificate.
  
Actual results:

Installation fails with

Where is your satellite certificate file? /root/redhat-internal-devel.cert?rev=187008
** Loading RHN Satellite Certificate.
** Verifying certificate locally.
** Activating RHN Satellite.
There was a problem activating the satellite: Remote activation failure.

and rhn-satellite-activate fails as well.

Expected results:

No failure, Satellite activated.

Additional info:

Comment 1 Jan Pazdziora 2009-09-14 15:12:08 UTC
For the record, I just activated Satellite 5.2 on RHEL 4 and on RHEL 5 during installation (= using the command line tool), with the following cert, just fine:

http://svn.rhndev.redhat.com/viewcvs/*checkout*/trunk/pm/satellite-certs/satellite-5.2/redhat-internal-devel.cert?rev=187010

Comment 2 Sebastian Skracic 2012-02-20 09:30:31 UTC
Could not reproduce.  Please reopen if the problem still persists.


Note You need to log in before you can comment on or make changes to this bug.