Bug 523257 - [abrt] crash detected in pulseaudio-0.9.17-1.fc12
Summary: [abrt] crash detected in pulseaudio-0.9.17-1.fc12
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: pulseaudio
Version: rawhide
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:f4a7d05a3a9e1d00937e58514cf...
: 591792 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-14 15:36 UTC by Michal Schmidt
Modified: 2010-09-29 21:08 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-18 22:32:41 UTC


Attachments (Terms of Use)
File: backtrace (5.57 KB, text/plain)
2009-09-14 15:36 UTC, Michal Schmidt
no flags Details

Description Michal Schmidt 2009-09-14 15:36:05 UTC
abrt detected a crash.


How to reproduce
-----
not sure

Comment
-----
I'm not sure what exactly caused PA to crash. I was not running any sound-playing application, and I think the only process that could have produced sound at the time of the crash was Jabbim - an XMPP client which calls 'aplay' to make its sounds. I may have used my laptop's volume control knob at the time too.

Possibly related: I have this in my ~/.bash_profile:
export MALLOC_CHECK_=3
# http://udrepper.livejournal.com/11429.html
export MALLOC_PERTURB_=$(($RANDOM % 255 + 1))

In this particular session, the random value was:
MALLOC_PERTURB_=116

Additional information
======


Attached files
----
backtrace

cmdline
-----
/usr/bin/pulseaudio --start --log-target=syslog 


component
-----
pulseaudio


executable
-----
/usr/bin/pulseaudio


kernel
-----
2.6.31-2.fc12.x86_64


package
-----
pulseaudio-0.9.17-1.fc12


reason
-----
Process was terminated by signal 6

Comment 1 Michal Schmidt 2009-09-14 15:36:08 UTC
Created attachment 360962 [details]
File: backtrace

Comment 2 Lennart Poettering 2009-09-18 22:32:15 UTC
I am quite confident that this is now fixed with upstream commit r996051e.
Should enter Rawhide soon.

Comment 3 Hamidou Dia 2010-09-29 21:08:45 UTC
*** Bug 591792 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.