Bug 523445 - Error while loading anaconda - No module named system_config_keyboard.keyboard
Summary: Error while loading anaconda - No module named system_config_keyboard.keyboard
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda
Version: 6.0
Hardware: s390x
OS: Linux
high
medium
Target Milestone: alpha
: 6.0
Assignee: Anaconda Maintenance Team
QA Contact: Martin Banas
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-15 14:42 UTC by Martin Banas
Modified: 2010-11-11 14:31 UTC (History)
5 users (show)

Fixed In Version: anaconda-12.34.1-1.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-11 14:31:22 UTC


Attachments (Terms of Use)

Description Martin Banas 2009-09-15 14:42:19 UTC
Description of problem:
While installing RHEL6.0-20090915.0, anaconda ends with error:
ImportError: No module named system_config_keyboard.keyboard

Version-Release number of selected component (if applicable):
RHEL6.0-20090915.0
anaconda 12.24
s390x

How reproducible:
always

Steps to Reproduce:
1. run RHEL6 installer on s390x
2. proceed to stage2
  
Actual results:

Running anaconda 12.24, the redhat system installer - please wait.
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 609, in <module>
    instClass = getInstClass()
  File "/usr/bin/anaconda", line 333, in getInstClass
    from installclass import DefaultInstall
  File "/usr/lib/anaconda/installclass.py", line 31, in <module>
    from instdata import InstallData
  File "/usr/lib/anaconda/instdata.py", line 43, in <module>
    import system_config_keyboard.keyboard as keyboard
ImportError: No module named system_config_keyboard.keyboard


Expected results:
anaconda should start as expected.

Additional info:

Comment 1 RHEL Product and Program Management 2009-09-15 15:03:52 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 2 Chris Lumens 2009-09-16 13:38:51 UTC
Does updates=http://clumens.fedorapeople.org/523445.img help?

Comment 3 Martin Banas 2009-09-16 13:54:33 UTC
Hi Chris,
thanks for update, 
using updates=http://clumens.fedorapeople.org/523445.img anaconda starts as expected

Comment 4 Chris Lumens 2009-09-16 13:55:13 UTC
Great, then this is a fairly easy problem to solve.

Comment 5 Chris Lumens 2009-09-16 15:27:26 UTC
I've pushed the anaconda portion of this fix to the git repo.  Please make sure that system-config-keyboard is pulled into the trees for all architectures for RHEL6, since it provides these modules.

Comment 6 Martin Banas 2009-10-15 06:32:13 UTC
Verified, not happening on RHEL6.0-20091006 with anaconda 12.34.

Comment 7 releng-rhel@redhat.com 2010-11-11 14:31:22 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.