Bug 523506 - Fresh install unusable because of SELinux labeling issues
Summary: Fresh install unusable because of SELinux labeling issues
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Chris Lumens
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-15 18:25 UTC by Orion Poplawski
Modified: 2009-10-23 22:20 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-23 22:20:34 UTC


Attachments (Terms of Use)
install.log (70.36 KB, text/plain)
2009-09-15 20:05 UTC, Orion Poplawski
no flags Details
anaconda.log (116.38 KB, text/plain)
2009-09-15 20:06 UTC, Orion Poplawski
no flags Details
anaconda.syslog (52.49 KB, text/plain)
2009-09-15 20:07 UTC, Orion Poplawski
no flags Details

Description Orion Poplawski 2009-09-15 18:25:55 UTC
Description of problem:

Did a fresh install of rawhide this morning, cannot log in as root:

# ssh ventus
Unable to get valid context for root
Last login: Tue Sep 15 11:32:08 2009
Connection to ventus closed.

Did a restorecon -r -v and it seems almost everything was labeled "system_u:object_r:file_t".

Still haven't gotten the system working yet.

Comment 1 Daniel Walsh 2009-09-15 19:51:00 UTC
Orion can you attach the anaconda install logs

Comment 2 David Lehman 2009-09-15 19:54:35 UTC
It would be useful if someone who has hit this could attach /root/install.log,
/var/log/anaconda.log, /var/log/anaconda.syslog from the installed system.

Comment 3 Orion Poplawski 2009-09-15 20:05:19 UTC
Created attachment 361131 [details]
install.log

Comment 4 Orion Poplawski 2009-09-15 20:06:16 UTC
Created attachment 361132 [details]
anaconda.log

Comment 5 Orion Poplawski 2009-09-15 20:07:14 UTC
Created attachment 361133 [details]
anaconda.syslog

Comment 6 Orion Poplawski 2009-09-15 20:08:26 UTC
Is the "relabel" boot argument still supposed to work?  Doesn't seem to be doing anything.

Comment 7 Daniel Walsh 2009-09-15 20:12:08 UTC
You mean autorelabel?

touch /.autorelabel

Should work also

Comment 8 Orion Poplawski 2009-09-15 20:34:10 UTC
Ah, that's it.  After than I can log in.

Comment 9 Orion Poplawski 2009-09-15 21:26:27 UTC
Same thing happened on my i686 desktop install (previous was a x86_64 laptop), so 2 for 2 now.

Comment 10 Daniel Walsh 2009-09-15 21:47:15 UTC
I think this may be being caused by a change to load_policy that moved load_policy from /usr/sbin to /sbin.  I have just committed a patch to link the two files.

Comment 11 David Cantrell 2009-09-15 22:22:44 UTC
Fix will be in anaconda-12.25-1.


Note You need to log in before you can comment on or make changes to this bug.