Bug 523586 - setroubleshoot: SELinux is preventing /usr/sbin/abrtd "create" access on abrt-db-journal.
Summary: setroubleshoot: SELinux is preventing /usr/sbin/abrtd "create" access on abrt...
Keywords:
Status: CLOSED DUPLICATE of bug 523585
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:3e7161460fe...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-16 02:50 UTC by al morris
Modified: 2009-09-16 12:43 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-16 12:43:55 UTC


Attachments (Terms of Use)

Description al morris 2009-09-16 02:50:13 UTC
The following was filed automatically by setroubleshoot:

Summary:

SELinux is preventing /usr/sbin/abrtd "create" access on abrt-db-journal.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by abrtd. It is not expected that this access is
required by abrtd and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:initrc_t:s0
Target Context                system_u:object_r:var_t:s0
Target Objects                abrt-db-journal [ file ]
Source                        abrtd
Source Path                   /usr/sbin/abrtd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           abrt-0.0.8.5-1.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.31-3.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.31-12.fc12.x86_64 #1 SMP Mon Sep 14
                              02:11:46 EDT 2009 x86_64 x86_64
Alert Count                   1
First Seen                    Tue 15 Sep 2009 09:48:39 PM CDT
Last Seen                     Tue 15 Sep 2009 09:48:39 PM CDT
Local ID                      746558a2-f705-4ee6-bb25-101fb07921a3
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1253069319.749:79): avc:  denied  { create } for  pid=1412 comm="abrtd" name="abrt-db-journal" scontext=system_u:system_r:initrc_t:s0 tcontext=system_u:object_r:var_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1253069319.749:79): arch=c000003e syscall=2 success=yes exit=8 a0=2015cc8 a1=42 a2=1a4 a3=8 items=0 ppid=1 pid=1412 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="abrtd" exe="/usr/sbin/abrtd" subj=system_u:system_r:initrc_t:s0 key=(null)


audit2allow suggests:

#============= initrc_t ==============
allow initrc_t var_t:file create;

Comment 1 Daniel Walsh 2009-09-16 12:43:55 UTC

*** This bug has been marked as a duplicate of bug 523585 ***


Note You need to log in before you can comment on or make changes to this bug.