Bug 523587 - setroubleshoot: SELinux is preventing /usr/sbin/abrtd "unlink" access on ccpp-1253069319-2245.lock.
Summary: setroubleshoot: SELinux is preventing /usr/sbin/abrtd "unlink" access on ccpp...
Keywords:
Status: CLOSED DUPLICATE of bug 523585
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:0beb25def1d...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-16 02:51 UTC by al morris
Modified: 2009-09-16 12:44 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-16 12:44:13 UTC


Attachments (Terms of Use)

Description al morris 2009-09-16 02:51:54 UTC
The following was filed automatically by setroubleshoot:

Summary:

SELinux is preventing /usr/sbin/abrtd "unlink" access on
ccpp-1253069319-2245.lock.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by abrtd. It is not expected that this access is
required by abrtd and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:initrc_t:s0
Target Context                system_u:object_r:var_t:s0
Target Objects                ccpp-1253069319-2245.lock [ file ]
Source                        abrtd
Source Path                   /usr/sbin/abrtd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           abrt-0.0.8.5-1.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.31-3.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.31-12.fc12.x86_64 #1 SMP Mon Sep 14
                              02:11:46 EDT 2009 x86_64 x86_64
Alert Count                   1
First Seen                    Tue 15 Sep 2009 09:48:39 PM CDT
Last Seen                     Tue 15 Sep 2009 09:48:39 PM CDT
Local ID                      93db7021-f6f9-44f2-a16c-5db59641fecf
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1253069319.747:76): avc:  denied  { unlink } for  pid=1412 comm="abrtd" name="ccpp-1253069319-2245.lock" dev=sda2 ino=89110 scontext=system_u:system_r:initrc_t:s0 tcontext=system_u:object_r:var_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1253069319.747:76): arch=c000003e syscall=87 success=yes exit=0 a0=2015d48 a1=0 a2=0 a3=4000 items=0 ppid=1 pid=1412 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="abrtd" exe="/usr/sbin/abrtd" subj=system_u:system_r:initrc_t:s0 key=(null)


audit2allow suggests:

#============= initrc_t ==============
allow initrc_t var_t:file unlink;

Comment 1 Daniel Walsh 2009-09-16 12:44:13 UTC

*** This bug has been marked as a duplicate of bug 523585 ***


Note You need to log in before you can comment on or make changes to this bug.