Bug 52361 - Roswell2 kickstart now stomps on Windows installation
Summary: Roswell2 kickstart now stomps on Windows installation
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: roswell
Hardware: All Linux
high
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-23 02:49 UTC by ajs
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-23 23:07:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description ajs 2001-08-23 02:49:01 UTC
Description of Problem:

Starting with Roswell2 the kickstart installer removes my Windows 2000
installation which resided on the first partition of my hard drive.

The partitioning section of my kickstart file is:

zerombr yes
clearpart --linux --drives=hda
part /boot --fstype ext3 --size=50 --ondisk=hda
part / --fstype ext3 --size=1100 --grow --ondisk=hda
part swap --size=880 --grow --maxsize=1760 --ondisk=hda


This worked just fine on Roswell #1.

Version-Release number of selected component (if applicable):


How Reproducible:
Always

Steps to Reproduce:
1. Install Win2k on first partition
2. Use kickstart to install Linux on the rest of the drive.

Actual Results:


Expected Results:


Additional Information:

Comment 1 Brent Fox 2001-08-23 19:08:17 UTC
katzj, have you seen any behavior like this?  I don't think this code changed
between Roswell 1 and Roswell 2.

Comment 2 Michael Fulbright 2001-08-23 22:29:40 UTC
Its because zerombr is ONLY supposed to remove the mbr if it is BAD.

Read the RH 5.0 installer code.

Comment 3 ajs 2001-08-23 23:04:54 UTC
It seems to do more than mess with the mbr (unless the mbr also has something to
do with the partition table that I'm not aware of) --- the fat32 partition is
completely removed.  I'm hesitant to reproduce this again since it takes so
damned long to install Windows 2000, but I think that there was a message on the
console where partition information is reported that may have said something
about not liking one of the partitions just before it created the linux
partitions.  Could it be that the partition table is misread?

Comment 4 Jeremy Katz 2001-08-23 23:06:47 UTC
Yes, the fact that this happens is a bug... I've got a patch which I'm testing
at the moment

Comment 5 Jeremy Katz 2001-08-23 23:18:39 UTC
Fixed in CVS

Comment 6 ajs 2001-08-24 14:54:43 UTC
Is there somewhere a bootnet.img with the new fixes that I could use to test things?

Comment 7 Jeremy Katz 2001-08-24 16:50:05 UTC
Unfortunately, the files which were changed have diverged a little bit too much
to easily create an updates disk with the fix without having to basically redo
the diff against the older tree.


Note You need to log in before you can comment on or make changes to this bug.