This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 52362 - rpm is not working after upgrade
rpm is not working after upgrade
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: rpm (Show other bugs)
roswell
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-22 23:03 EDT by sahag
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-23 10:22:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sahag 2001-08-22 23:03:43 EDT
Description of Problem:
after upgrading to Roswell2 my rpm stopped woring.
this is the output that I get when executing rpm -q rpm

[root@ani sahak]# rpm -q rpm
rpmdb: Program version 3.3.11 doesn't match environment version 3.3.4
error: db3 error(22) from dbenv->open: Invalid argument
error: cannot open Packages index using db3 - Invalid argument (22)

Version-Release number of selected component (if applicable):


How Reproducible:
always

Steps to Reproduce:
1. login as root
2. run any rpm query


Actual Results:


Expected Results:


Additional Information:
Comment 1 Sammy 2001-08-23 10:22:30 EDT
The same problem was solved for me by doing rpm --rebuilddb
though it is unusual since upto now I did not have to this.
Comment 2 Jeff Johnson 2001-08-23 11:52:39 EDT
Try
	rm /var/lib/rpm/__db*

This is now done at rpm startup as of rpm-4.0.3-0.88.
Comment 3 Ed McKenzie 2001-08-30 22:17:46 EDT
rpm still does the complete hang bit for me, and it seems to happen more often
after I've hit ^C to interrupt an install ... this is with .93

Note You need to log in before you can comment on or make changes to this bug.