Bug 523638 - [RHEL6 Xen]: Support PV PCI passthrough?
Summary: [RHEL6 Xen]: Support PV PCI passthrough?
Keywords:
Status: CLOSED DUPLICATE of bug 611423
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Xen Maintainance List
QA Contact: Martin Jenner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-16 09:34 UTC by Chris Lalancette
Modified: 2011-01-05 10:10 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-01-05 10:00:59 UTC


Attachments (Terms of Use)

Description Chris Lalancette 2009-09-16 09:34:48 UTC
Description of problem:
RHEL-5 Xen domU currently supports the ability to passthrough a PCI device to a paravirtualized guest.  While this isn't secure, it does have uses.  Upstream LKML domU support does not currently support this mode.  Should we port this over?

Comment 1 RHEL Product and Program Management 2009-09-16 09:36:55 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Pasi Karkkainen 2010-11-19 08:53:20 UTC
xen-pcifront support for PCI passthrough to PV domU is now included in the upstream 2.6.37 kernel.

It would be very welcome addition for the el6 kernel!

Comment 4 Paolo Bonzini 2011-01-05 10:00:59 UTC

*** This bug has been marked as a duplicate of bug 611423 ***


Note You need to log in before you can comment on or make changes to this bug.