Bug 523664 - Turn on and off Visualization effect while the music is being played and totem freezes
Summary: Turn on and off Visualization effect while the music is being played and tote...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: totem
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 523785 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-16 11:43 UTC by Michal Nowak
Modified: 2013-03-08 02:06 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-16 13:31:15 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 583255 None None None Never

Description Michal Nowak 2009-09-16 11:43:45 UTC
Description of problem:

Turn on and off Visualization effect while the music is being played and totem freezes.

Version-Release number of selected component (if applicable):

totem-2.27.92-1.fc12.i686
(fully updated Rawhide)

How reproducible:
always

Steps to Reproduce:

Open Totem -> Enable Visual effects in Preferences -> Quit Totem -> Open Totem -> Play some music (http://www.archive.org/download/AKINC.AUTOMATICDOWNWARDSPIRAL/09_to_the_suburbs.ogg in my case) -> Disable Visual  effects in Preferences -> Go to third tab "Audio" and Totem's UI is frozen while sound is playing OK.
  
Actual results:


Expected results:


Additional info:

newman SPECS $ strace -p `pgrep totem`
Process 14615 attached - interrupt to quit
futex(0x9039a90, FUTEX_WAIT_PRIVATE, 2, NULL

Comment 1 Bastien Nocera 2009-09-16 13:31:15 UTC
Known upstream bug.

See https://bugzilla.gnome.org/show_bug.cgi?id=583255

Comment 2 Bastien Nocera 2009-09-16 16:53:02 UTC
*** Bug 523785 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.