Bug 523716 - setroubleshoot: SELinux is preventing the /usr/bin/kdm from using potentially mislabeled files (.Xauthority-c).
Summary: setroubleshoot: SELinux is preventing the /usr/bin/kdm from using potent...
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:bc8195db8f2...
: 523717 523718 523719 523722 523742 523743 523744 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-16 14:27 UTC by STEVEN WARD
Modified: 2009-09-16 16:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-16 15:53:37 UTC


Attachments (Terms of Use)

Description STEVEN WARD 2009-09-16 14:27:34 UTC
The following was filed automatically by setroubleshoot:

Summary:

SELinux is preventing the /usr/bin/kdm from using potentially mislabeled files
(.Xauthority-c).

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux has denied kdm access to potentially mislabeled file(s) (.Xauthority-c).
This means that SELinux will not allow kdm to use these files. It is common for
users to edit files in their home directory or tmp directories and then move
(mv) them to system directories. The problem is that the files end up with the
wrong file context which confined applications are not allowed to access.

Allowing Access:

If you want kdm to access this files, you need to relabel them using restorecon
-v '.Xauthority-c'. You might want to relabel the entire directory using
restorecon -R -v ''.

Additional Information:

Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:xauth_home_t:s0
Target Objects                .Xauthority-c [ file ]
Source                        kdm
Source Path                   /usr/bin/kdm
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           kdm-4.3.1-1.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.31-2.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Permissive
Plugin Name                   home_tmp_bad_labels
Host Name                     (removed)
Platform                      Linux (removed) 2.6.31-2.fc12.i686 #1 SMP Thu Sep
                              10 00:41:03 EDT 2009 i686 athlon
Alert Count                   2
First Seen                    Sat 12 Sep 2009 07:12:36 AM BST
Last Seen                     Sat 12 Sep 2009 07:49:06 AM BST
Local ID                      6549bd41-1ffc-4456-8b4a-1b4992f23fa5
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1252738146.187:104): avc:  denied  { link } for  pid=6926 comm="kdm" name=".Xauthority-c" dev=dm-0 ino=8317 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:xauth_home_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1252738146.187:104): arch=40000003 syscall=9 success=yes exit=0 a0=bf8508ab a1=bf8504aa a2=aa4bb8 a3=1 items=0 ppid=6891 pid=6926 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=5 comm="kdm" exe="/usr/bin/kdm" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)


audit2allow suggests:

#============= xdm_t ==============
allow xdm_t xauth_home_t:file link;

Comment 1 Daniel Walsh 2009-09-16 15:53:37 UTC
This would not happen in enforcing mode and you are not trying to login as root correct?

So I can not fix,  You can just remove the /root/.Xauth* files and this will no longer happen.

Comment 2 Daniel Walsh 2009-09-16 15:54:04 UTC
*** Bug 523717 has been marked as a duplicate of this bug. ***

Comment 3 Daniel Walsh 2009-09-16 15:54:27 UTC
*** Bug 523718 has been marked as a duplicate of this bug. ***

Comment 4 Daniel Walsh 2009-09-16 15:54:48 UTC
*** Bug 523719 has been marked as a duplicate of this bug. ***

Comment 5 Daniel Walsh 2009-09-16 15:57:20 UTC
*** Bug 523722 has been marked as a duplicate of this bug. ***

Comment 6 Daniel Walsh 2009-09-16 16:06:55 UTC
*** Bug 523744 has been marked as a duplicate of this bug. ***

Comment 7 Daniel Walsh 2009-09-16 16:07:02 UTC
*** Bug 523743 has been marked as a duplicate of this bug. ***

Comment 8 Daniel Walsh 2009-09-16 16:07:11 UTC
*** Bug 523742 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.