Bug 523717 - setroubleshoot: SELinux is preventing the /usr/bin/kdm from using potentially mislabeled files (.Xauthority-n).
Summary: setroubleshoot: SELinux is preventing the /usr/bin/kdm from using potent...
Keywords:
Status: CLOSED DUPLICATE of bug 523716
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:d839a44af7c...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-16 14:28 UTC by STEVEN WARD
Modified: 2009-09-16 15:54 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-16 15:54:04 UTC


Attachments (Terms of Use)

Description STEVEN WARD 2009-09-16 14:28:12 UTC
The following was filed automatically by setroubleshoot:

Summary:

SELinux is preventing the /usr/bin/kdm from using potentially mislabeled files
(.Xauthority-n).

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux has denied kdm access to potentially mislabeled file(s) (.Xauthority-n).
This means that SELinux will not allow kdm to use these files. It is common for
users to edit files in their home directory or tmp directories and then move
(mv) them to system directories. The problem is that the files end up with the
wrong file context which confined applications are not allowed to access.

Allowing Access:

If you want kdm to access this files, you need to relabel them using restorecon
-v '.Xauthority-n'. You might want to relabel the entire directory using
restorecon -R -v ''.

Additional Information:

Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:xauth_home_t:s0
Target Objects                .Xauthority-n [ file ]
Source                        kdm
Source Path                   /usr/bin/kdm
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           kdm-4.3.1-1.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.31-2.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Permissive
Plugin Name                   home_tmp_bad_labels
Host Name                     (removed)
Platform                      Linux (removed) 2.6.31-2.fc12.i686 #1 SMP Thu Sep
                              10 00:41:03 EDT 2009 i686 athlon
Alert Count                   2
First Seen                    Sat 12 Sep 2009 07:12:36 AM BST
Last Seen                     Sat 12 Sep 2009 07:49:06 AM BST
Local ID                      319d0b53-f468-4712-a392-e27c6a4beb2e
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1252738146.192:105): avc:  denied  { setattr } for  pid=6926 comm="kdm" name=".Xauthority-n" dev=dm-0 ino=8770 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:xauth_home_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1252738146.192:105): arch=40000003 syscall=15 success=yes exit=0 a0=bf850d8a a1=180 a2=bf850d8a a3=84587b0 items=0 ppid=6891 pid=6926 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=5 comm="kdm" exe="/usr/bin/kdm" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)


audit2allow suggests:

#============= xdm_t ==============
allow xdm_t xauth_home_t:file setattr;

Comment 1 Daniel Walsh 2009-09-16 15:54:04 UTC

*** This bug has been marked as a duplicate of bug 523716 ***


Note You need to log in before you can comment on or make changes to this bug.