Bug 523722 - setroubleshoot: SELinux is preventing /usr/libexec/polkit-1/polkitd "open" access on /root/.config/user-dirs.dirs.
Summary: setroubleshoot: SELinux is preventing /usr/libexec/polkit-1/polkitd "open" ac...
Keywords:
Status: CLOSED DUPLICATE of bug 523716
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:c5e81bdfd3e...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-16 14:30 UTC by STEVEN WARD
Modified: 2009-09-16 15:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-16 15:57:20 UTC


Attachments (Terms of Use)

Description STEVEN WARD 2009-09-16 14:30:35 UTC
The following was filed automatically by setroubleshoot:

Summary:

SELinux is preventing /usr/libexec/polkit-1/polkitd "open" access on
/root/.config/user-dirs.dirs.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by polkitd. It is not expected that this access
is required by polkitd and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:policykit_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:admin_home_t:s0
Target Objects                /root/.config/user-dirs.dirs [ file ]
Source                        polkitd
Source Path                   /usr/libexec/polkit-1/polkitd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           polkit-0.94-4.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.31-3.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.31-2.fc12.i686 #1 SMP Thu Sep
                              10 00:41:03 EDT 2009 i686 athlon
Alert Count                   1
First Seen                    Sat 12 Sep 2009 04:29:46 PM BST
Last Seen                     Sat 12 Sep 2009 04:29:46 PM BST
Local ID                      0a31b04d-5444-4bec-9158-33816a861878
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1252769386.317:33): avc:  denied  { open } for  pid=1588 comm="polkitd" name="user-dirs.dirs" dev=dm-0 ino=264906 scontext=system_u:system_r:policykit_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:admin_home_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1252769386.317:33): arch=40000003 syscall=5 success=yes exit=7 a0=951ae18 a1=8000 a2=0 a3=951acf0 items=0 ppid=1587 pid=1588 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="polkitd" exe="/usr/libexec/polkit-1/polkitd" subj=system_u:system_r:policykit_t:s0-s0:c0.c1023 key=(null)


audit2allow suggests:

#============= policykit_t ==============
allow policykit_t admin_home_t:file open;

Comment 1 Daniel Walsh 2009-09-16 15:57:20 UTC
Do not login as root via X This is unsupported.

You need to remove 

rm -rf /root/.config

*** This bug has been marked as a duplicate of bug 523716 ***


Note You need to log in before you can comment on or make changes to this bug.