Bug 523723 - setroubleshoot: SELinux is preventing /sbin/ldconfig "read" access on libfontenc.so.
Summary: setroubleshoot: SELinux is preventing /sbin/ldconfig "read" access on libfont...
Keywords:
Status: CLOSED DUPLICATE of bug 523720
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:8a12c1e643e...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-16 14:31 UTC by STEVEN WARD
Modified: 2009-09-16 15:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-16 15:57:57 UTC


Attachments (Terms of Use)

Description STEVEN WARD 2009-09-16 14:31:02 UTC
The following was filed automatically by setroubleshoot:

Summary:

SELinux is preventing /sbin/ldconfig "read" access on libfontenc.so.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by ldconfig. It is not expected that this access
is required by ldconfig and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                unconfined_u:unconfined_r:ldconfig_t:s0-s0:c0.c102
                              3
Target Context                unconfined_u:object_r:usr_t:s0
Target Objects                libfontenc.so [ lnk_file ]
Source                        ldconfig
Source Path                   /sbin/ldconfig
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           glibc-2.10.90-21
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.31-3.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.31-2.fc12.i686 #1 SMP Thu Sep
                              10 00:41:03 EDT 2009 i686 athlon
Alert Count                   1
First Seen                    Sat 12 Sep 2009 05:52:09 PM BST
Last Seen                     Sat 12 Sep 2009 05:52:09 PM BST
Local ID                      1df77475-834c-4aa3-9d41-da5680f219cd
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1252774329.434:38): avc:  denied  { read } for  pid=5420 comm="ldconfig" name="libfontenc.so" dev=dm-0 ino=826905 scontext=unconfined_u:unconfined_r:ldconfig_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:usr_t:s0 tclass=lnk_file

node=(removed) type=SYSCALL msg=audit(1252774329.434:38): arch=40000003 syscall=195 success=yes exit=0 a0=bf93bd90 a1=bf93cdcc a2=1 a3=876ffa0 items=0 ppid=5398 pid=5420 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=pts2 ses=1 comm="ldconfig" exe="/sbin/ldconfig" subj=unconfined_u:unconfined_r:ldconfig_t:s0-s0:c0.c1023 key=(null)


audit2allow suggests:

#============= ldconfig_t ==============
allow ldconfig_t usr_t:lnk_file read;

Comment 1 Daniel Walsh 2009-09-16 15:57:57 UTC

*** This bug has been marked as a duplicate of bug 523720 ***


Note You need to log in before you can comment on or make changes to this bug.