Bug 52378 - filesystem layer hosage
filesystem layer hosage
Status: CLOSED DUPLICATE of bug 82238
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Stephen Tweedie
Brock Organ
:
: 74294 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-23 06:50 EDT by Nils Philippsen
Modified: 2008-01-17 12:49 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Oops #1 (2.55 KB, patch)
2001-08-24 02:00 EDT, Nils Philippsen
no flags Details | Diff
ksymoops of oops #1 (9.41 KB, text/plain)
2001-08-24 02:03 EDT, Nils Philippsen
no flags Details
Oops #2 (3.72 KB, text/plain)
2001-08-24 02:04 EDT, Nils Philippsen
no flags Details
ksymoops of oops #2 (10.27 KB, text/plain)
2001-08-24 02:05 EDT, Nils Philippsen
no flags Details
ksymoops of oops #2 (10.27 KB, text/plain)
2001-08-24 02:06 EDT, Nils Philippsen
no flags Details
ksymoops of oops #2 (10.27 KB, text/plain)
2001-08-24 02:07 EDT, Nils Philippsen
no flags Details
ksymoops of oops #2 (10.27 KB, text/plain)
2001-08-24 02:08 EDT, Nils Philippsen
no flags Details

  None (edit)
Description Nils Philippsen 2001-08-23 06:50:46 EDT
[ Re kernel version 2.4.7-2 ]

Recently, I managed to sink my /usr filesystem (ext3) by running an fsck
on it while it was still mounted (rw, don't ask). I ended up with decently
filled /usr/lost+found and managed to restore most of the filesystem
by rpm means. In the attempt to salvage as much of the remainder from
lost+found, I tried to delete all files which weren't either normal files
or directormes (i.e. mostly junk because not even the permissions, owner
or group were remotely sane) this way:

cd /usr/lost+found
for i in *; do
        if [ ! -f "$i" -a ! -d "$i" ]; then
                echo "$i"
                rm -f "$i"
        fi
done

It stopped after one file with this kernel error:

wombat kernel: Assertion failure in do_get_write_access() at 
transaction.c:679: "handle->h_buffer_credits > 0"

The offending file is:

sr-S------    1 52518    51480           0 Dec 20  1942 #212051

After that, the machine was only partially responsive -- i.e. the sshd
processes were still active but the FS layer seemed to be hosed (I tried
to log in again, and came as far as typing in the password, then nothing
happened anymore). After ca. 1 hour, apparently my provider cut the DSL
connection, at exactly the moment where I tried to copy and paste the list
of the junk files onto another box (I managed to copy about half of the
list of files).

I can't say how or if this is reproducible, but I'll take a look at the
machine to get additional info (if this is possible -- an oops or
something) when I'm home again.
Comment 1 Nils Philippsen 2001-08-24 02:00:00 EDT
Ok, I managed to get 2 oopses immediately after the offending rm. I'll attach the
oopses and the ksymoops output (though it whined a lot about symbol mismatches
-- probably due to System.map and vmlinux being for the i386 arch and the kernel
is athlon).
Comment 2 Nils Philippsen 2001-08-24 02:00:51 EDT
Created attachment 29337 [details]
Oops #1
Comment 3 Nils Philippsen 2001-08-24 02:03:12 EDT
Created attachment 29338 [details]
ksymoops of oops #1
Comment 4 Nils Philippsen 2001-08-24 02:04:01 EDT
Created attachment 29339 [details]
Oops #2
Comment 5 Nils Philippsen 2001-08-24 02:05:45 EDT
Created attachment 29340 [details]
ksymoops of oops #2
Comment 6 Nils Philippsen 2001-08-24 02:06:09 EDT
Created attachment 29341 [details]
ksymoops of oops #2
Comment 7 Nils Philippsen 2001-08-24 02:07:37 EDT
Created attachment 29342 [details]
ksymoops of oops #2
Comment 8 Nils Philippsen 2001-08-24 02:08:51 EDT
Created attachment 29343 [details]
ksymoops of oops #2
Comment 9 Nils Philippsen 2001-08-24 02:10:54 EDT
Whoops. Sorry for too much attachments, somehow bugzilla didn't tell me that it
created anything (it just was loading and loading...).
Comment 10 Stephen Tweedie 2001-08-24 05:17:40 EDT
Did e2fsck warn that the fs was mounted and tell you you should not proceed?  If
that warning was omitted and you unwittingly fscked a live filesystem, then
that's  serious and needs to be a bug opened against e2fsprogs.  Otherwise, this
is a "well don't do that!" situation.  I'll hunt for the oops --- the kernel
shouldn't panic even if you do something stupid to it --- but there are no
guarantees if you do this to a live filesystem.

Second question --- did you reboot between the live fsck and the oops?

Third question --- the assert failure you got (the buffer credits one) will have
provided you with a BUG backtrace telling you where the failure occurred.  In
all such kernel faults, it is *always* the first oops which is the most
important (the others are often just side effects of the first disaster.)  Do
you have a ksymoops trace for the first assert failure?

Thanks.
Comment 11 Nils Philippsen 2001-08-24 07:05:46 EDT
Re e2fsck warning:

no it didn't, most likely because I specified "-f" to check an FS marked
"clean". Perhaps it should distinguish between forcing to check a clean FS and
forcing to do stupid things ("-f" and "-F" or "--force-doing-stupid-things").
Another idea I have is that it didn't cope too well with the runnning devfs I
had at that time.

Re reboot between live fsck and oops:

The short answer is: yes. Let me depict what I did (the hosed FS was mounted as
/usr, it was ext3):

Old kernel (2.4.8-ac7 or -ac8, devfs):

- Fscked live file system
- Realized that this wasn't too clever
- umounted FS
- Fscked (now dead) FS
- ended up with rather impressive lost+found (everything inside, nothing
  outside) and the journal inode removed from the FS (ext2 again)
- Tried to reinstall software with rpm, didn't work out due to
  missing /usr/lib/rpm and missing /usr/bin/rpm2cpio (this should go into
  /bin, it's needed when catastrphies occur)
7.1 Rescue CD:

- Reinstall rpm
- chroot into the system
- Reinstall every already installed package I could get hold of (luckily I
  didn't shoot /var)

7.2beta kernel 2.4.7-2

- single mode, umount /usr
- tune2fs -j the FS to get journalling again
- Try to salvage configuration files, /usr/local and other valuable stuff- In
that course I wanted to remove all files I couldn't use any more, i.e.
  (erroneous) device files, pipes, sockets --> Oops & normal file operations
  didn't work any more
- Reboot (journals were recovered well)
- Stayed away from lost+found since :-)

Re: oops

The oops and the ksymoops output are already in the attachments oops1.txt and
oops1.txt.ksymoopsed.
Comment 12 Stephen Tweedie 2001-08-24 09:13:17 EDT
Which e2fsprogs?  With my non-devfs systems, "fsck -f" *will* still prompt
before touching a mounted filesystem.  If yours did not, then that's a fsck or
devfs bug: rpm -qf e2fsprogs to find which version you are running.

Do you still have the /lost+found which causes the problem?  If so, I'd love to
do some more debugging on it to find out what underlying situation is causing
this particular error.
Comment 13 Nils Philippsen 2001-08-24 09:45:47 EDT
It's e2fsprogs-1.22-3 and I still have the lost+found (minus some of the bogus
iles it managed to delete and some files that were in /usr/local/sbin -- I found 
them before and moved them to the right place again).

Unfortunately, I don't know how you could sensibly debug the lost+found as to
use debugfs I'd have to umount /usr and wouldn't have connectivity or sshd
running either... I'm sure you have an idea how to get around this, though ;-).
Comment 14 Stephen Tweedie 2001-08-24 10:46:38 EDT
That's OK, debugfs will run safely on a live filesystem: debugging a fs is a
readonly operation by default (debugfs -w, which lets you modify a filesystem,
is more dangerous and will complain if you try it on a live fs, but we don't
need to do that in this case.)

Given that we know the inode number of the bad file, all you need to do is run
the command

debugfs> stat <212051>

inside debugfs.  The angle-brackets are necessary, btw --- they tell debugfs to
interpret the argument as an inode number rather than a pathname.

Thanks!
Comment 15 Glen Foster 2001-08-24 11:55:05 EDT
We (Red Hat) should try to fix this before next release.
Comment 16 Nils Philippsen 2001-08-24 12:16:13 EDT
Here we go (this looks seriously messed):

--- 8< --- snip ---
debugfs:  stat <212051>

Inode: 212051   Type: socket    Mode:  0400   Flags: 0x29a06   Generation: 0
User: 52518   Group: 51480   Size: 0
File ACL: 0    Directory ACL: 0
Links: 1   Blockcount: -853096168
Fragment:  Address: 0    Number: 0    Size: 0
ctime: 0xc18edf84 -- Wed Oct 21 00:38:44 1936
atime: 0xcd26c748 -- Sun Dec 20 05:42:48 1942
mtime: 0xcd26c910 -- Sun Dec 20 05:50:24 1942
BLOCKS:
(0):-2119956474, (1):1, (2):500, (3):100, (5):20, (7):998129380, (8):985540849, 
(9):985540849, (10):4096, (11):8, (IND):180325, (12):1886351732, (13):1869377136
, (14):1751539317, (15):1515276628, (16):55070558, (17):1986973784, (18):1985109
095, (19):2054318700, (20):1971088251, (21):1583047018, (22):1583308389, (23):14
31462498, (24):456023657, (25):873343538, (26):1919838827, (27):1041963370, (28)
:471543661, (29):1701128466, (30):1532913267, (31):1818911845, (32):1718447727, 
(33):1483106147, (34):1768184922, (35):1734946885, (36):1701206883, (37):1661034
591, (38):-33528575, (39):1363887957, (40):1701470299, (41):1279941220, (42):117
9074111, (43):405089598, (44):1548503625, (45):1446128219, (46):1718120041, (47)
:1497850731, (48):1665150559, (49):1245992778, (50):1380336714, (51):1566399573,
 (52):825772369, (53):438392373, (54):1312435742, (55):1398496089, (56):12131602
80, (57):1413494059, (58):1768445268, (59):1599038057, (60):1650874722, (61):144
8830050, (62):1481921878, (63):1701930334, (64):1751475813, (65):2088068713, (66
):2054977401, (67):2054451312, (68):1835758967, (69):1752463486, (70):1877110125
, (71):1835624814, (72):1954051957, (73):1684236917, (74):1936809056, (75):18025
97490, (76):1650944874, (77):1886285680, (78):2004448114, (79):1751018871, (80):
1531993960, (81):1431721050, (82):1902794841, (83):1380939636, (84):1886022772, 
(85):1634104951, (86):1432315230, (87):1600349022, (88):1130521184, (89):4427198
31, (90):257235746, (91):1985046111, (92):219304556, (93):471477852, (94):169751
7074, (95):-1688206486, (96):1701079911, (97):1802465902, (98):1466526825, (99):
1818774851, (100):1748963424, (101):1633769059, (102):22831972, (103):6291805, (
104):1162038155, (105):1447772225, (106):1482514516, (107):1202998019, (108):858
463038, (109):1028083010, (110):1296320837, (111):1684955998, (112):1247634540, 
(113):1648641846, (114):945577058, (115):1396917347, (116):1566398551, (117):126
4868955, (118):892679228, (119):859056161, (120):55790402, (121):1298570075, (12
2):910116436, (123):1565801001, (124):1768713833, (125):1802200936, (126):154955
9910, (127):1414813014, (128):-26344618, (129):1701011299, (130):2054843237, (13
1):2105244540, (132):2037411964, (133):1803189884, (134):1954051945, (135):18524
03313, (136):1818323568, (137):2054584184, (138):1617260407, (139):1937010539, (
140):1836152690, (141):1583968876, (142):1852402282, (143):2004448372, (144):181
8980471, (145):1481990250, (146):1481856592, (147):1818384729, (148):1684436854,
 (149):1768585592, (150):1464357470, (151):1415539817, (152):2020434788, (153):1
667917928, (154):225077088, (155):859706636, (156):1965702259, (157):218971491, 
(158):421140762, (159):1733168143, (160):1755144295, (161):1617523311, (162):171
8775401, (163):1667783771, (164):1734299464, (165):1398238313, (166):1633769576,
 (167):1819435099, (168):1526816769, (169):1027800576, (170):1364742980, (171):1
364216390, (172):1263225170, (173):959392071, (174):977550909, (175):1246380086,
 (176):1650613068, (177):1483761765, (178):1246832965, (179):1734697567, (180):1
064133730, (181):1566264113, (182):1431725149, (183):1027231311, (184):909593940
, (185):1785285453, (186):1465279854, (187):1280924508, (188):439167804, (189):1
785288769, (190):1549101161, (191):1549364333, (192):1465078620, (193):185272661
4, (194):1768315485, (195):2053992551, (196):2021353594, (197):2088530548, (198)
:2088664698, (199):2071622770, (200):1735882356, (201):1869574312, (202):2003853
671, (203):1953326708, (204):1969973867, (205):1987082360, (206):2021030264, (20
7):1835889266, (208):1903062380, (209):1954052472, (210):1668378990, (211):-7657
87297, (212):1499027271, (213):1903258986, (214):1886877306, (215):1264346475, (
216):1852533851, (217):1852139113, (218):1751674997, (219):1902339183, (220):789
724264, (221):273049178, (222):355235396, (223):455088909, (224):554438684, (225
):1734830672, (226):1567388778, (227):1835690337, (228):1481987421, (229):175166
8821, (230):678194279, (231):1228621424, (232):1912819792, (233):1325487873,
(234):1112669696, (235):1667457610, (236):1330863454, (237):1179207757, (238):99360
6203, (239):1229737276, (240):1364150608, (241):1650879841, (242):1617585511, (2
43):1665742914, (244):1515870542, (245):1769241974, (246):1144864098, (247):1449
549658, (248):978998614, (249):1616331829, (250):2003790693, (251):1852795760, (
252):1684169578, (253):1111901285, (254):1733574709, (255):1581996136, (256):155
0019683, (257):1683640146, (258):1668374115, (259):1498830679, (260):2003857770,
 (261):1652249211, (262):2086881611, (263):2105441659, (264):2104979574, (265):1
819178616, (266):1819177113, (267):1986749289, (268):1970104683, (269):197102655
2, (270):2021030265, (271):2021161336, (272):1879274873, (273):1869114084, (274)
:2004450422, (275):1685156211, (276):1331518817, (277):1532449858, (278):1936552
297, (279):1853192311, (280):1700291179, (281):1852005987, (282):2054646383, (28
3):1835954041, (284):1582524015, (285):353917033, (286):269514332, (287):4714069
44, (288):488709914, (289):1259081236, (290):1785292393, (291):1667592044, (292)
:1802333552, (293):1583178849, (294):1750885476, (295):2003790957, (296):1229530
231, (297):1852202589, (298):22937954, (299):1123942482, (300):1684228673, (301)
:1684432999, (302):1312963925, (303):1027490383, (304):1178484284, (305):1227966
284, (306):1735355734, (307):1701474148, (308):1548765280, (309):1298100838, (31
0):1970829179, (311):1045259375, (312):1633568832, (313):1734701674, (314):14965
28971, (315):1987077216, (316):1818849655, (317):1852468591, (318):1549690470, (
319):943605324, (320):927553116, (321):1516462668, (322):1347310678, (323):18177
94919, (324):1582189676, (325):2070705259, (326):575108728, (327):1293688418, (3
28):2122087804, (329):1819639679, (330):1651800445, (331):1919913844, (332):1734
830705, (333):1835756401, (334):2088466545, (335):-2038823818, (336):2021161592,
 (337):1879274102, (338):1835559063, (339):2071887480, (340):1634296948, (341):1
264149093, (342):1549226822, (343):1869574499, (344):1873571843, (345):139875952
9, (346):1919573857, (347):2071686770, (348):1852796282, (349):1683709030, (350)
:741286512, (351):1594908531, (352):572070217, (353):404692768, (354):1628441617
, (355):57239657, (356):1970379631, (357):1802268018, (358):1834378338, (359):18
35230064, (360):1601662060, (361):1330717235, (362):1549949537, (363):23396706, 
(364):805175394, (365):1482048315, (366):1650681948, (367):993876837, (368):1077
888586, (369):1430470460, (370):1448037967, (371):1667589486, (372):1701931107, 
(373):1734960492, (374):896823407, (375):1902863194, (376):1247241323, (377):151
5079485, (378):1937009767, (379):977429875, (380):1936812632, (381):1802597492, 
(382):1970303085, (383):1382115691, (384):1045122129, (385):1497907765, (386):13
80605284, (387):1213355858, (388):1817465955, (389):1532585047, (390):2020241257
, (391):1330736498, (392):1985890923, (393):2105304699, (394):1803255421, (395):
1802795638, (396):1869479535, (397):2003794035, (398):1869443191, (399):21053090
41, (400):2054847353, (401):2021489275, (402):1819506554, (403):1936881001, (404
):2122217331, (405):1953726076, (406):1868259947, (407):1363889764, (408):188621
7822, (409):1802133609, (410):1667131759, (411):1868783920, (412):2088006518, (4
13):1751937402, (414):1734697838, (415):276527196, (416):2021029195, (417):47127
5894, (418):522134306, (419):1158681617, (420):1935239276, (421):1968270194, (42
2):1919971188, (423):1919379820, (424):1886349683, (425):274560120, (426):119348
4307, (427):1650879811, (428):23421570, (429):5833058, (430):1263290366, (431):1
481592906, (432):1533105750, (433):1279674175, (434):1212501588, (435):143139362
1, (436):1718245205, (437):1886283109, (438):1786211180, (439):1852992882, (440)
:1179540592, (441):1684301394, (442):1027299689, (443):1733972809, (444):1919838
314, (445):1496003941, (446):1852863335, (447):1734699377, (448):1533044073, (44
9):1196708432, (450):858344027, (451):1633444679, (452):1398758207, (453):141658
6579, (454):940654932, (455):1801675622, (456):1214477936, (457):1935570972, (45
8):1803253360, (459):2071755641, (460):1987016567, (461):-1888652682, (462):1902
341229, (463):2054649713, (464):2037740146, (465):75070588, (466):1987505528, (4
67):1937079671, (468):1937076594, (469):2122020467, (470):2021489023, (471):1683
450231, (472):1280733039, (473):1785353035, (474):1734502253, (475):1566270827, 
(476):1785089882, (477):2087614333, (478):1735030908, (479):1684301670, (480):19
20167010, (481):1953657117, (482):252867957, (483):522265375, (484):488182037, (
485):724397126, (486):290282557, (487):1936814668, (488):1869442158, (489):15677
03924, (490):729447287, (491):254031632, (492):1701060930, (493):23291495, (494)
:6488413, (495):1296512644, (496):-28834996, (497):925452365, (498):1145520700, 
(499):1397510732, (500):1448630613, (501):1751671381, (502):1903235923, (503):18
17734764, (504):1870030701, (505):1668182637, (506):1766599723, (507):1011441768
, (508):1733314882, (509):1684956519, (510):976701806, (511):1801609032, (512):1
583638890, (513):1246586464, (514):1161576257, (515):1229481812, (516):143086752
5, (517):1617188948, (518):1617648215, (519):269565272, (520):1717789499, (521):
609451382, (522):1281652814, (523):2071688816, (524):2103862646, (525):196965055
5, (526):1920563576, (527):2020239213, (528):2123528057, (529):2037806196, (530)
:1970961532, (531):1970632310, (532):1987606647, (533):-1871379596, (534):198721
2660, (535):2105245052, (536):1399027325, (537):1416259671, (538):1792102147, (5
39):1684037482, (540):1532718948, (541):1666861647, (542):1734698601, (543):1684
628844, (544):1684097380, (545):1920101474, (546):2036153201, (547):252796277, (
548):539040534, (549):504304157, (550):455896092, (551):878470928, (552):1936870
175, (553):1869244528, (554):1901748857, (555):1316715314, (556):1616912941,
(557):1667457117, (558):1651472492, (559):1493262081, (560):1432026624, (561):15990
32657, (562):827019878, (563):623722048, (564):1313287974, (565):1465406547, (56
6):1701205853, (567):1158879318, (568):1195454833, (569):1936616803, (570):18843
15760, (571):944009069, (572):1499879489, (573):1431389000, (574):1768645457, (5
75):1651403883, (576):1599293243, (577):1768516456, (578):1448434779, (579):1297
701460, (580):1499811401, (581):1516267081, (582):1414614359, (583):1852332872, 
(584):339567975, (585):1718371097, (586):2021424247, (587):1786346363, (588):202
0766540, (589):1344174971, (590):1971027582, (591):2037806965, (592):1819177877,
 (593):1987801194, (594):1953788792, (595):2038201462, (596):1937077875, (597):1
996716662, (598):57963650, (599):1920459637, (600):2138733424, (601):1869839741,
 (602):1684362074, (603):1230065237, (604):1801271101, (605):1096509035, (606):1
733903161, (607):1415539049, (608):1717853274, (609):1717657954, (610):191977123
9, (611):1885760370, (612):257717858, (613):555228687, (614):303175197, (615):40
5281564, (616):693905684, (617):1903304477, (618):1886153590, (619):1664055673, 
(620):606359397, (621):1145379359, (622):1667456090, (623):1937274982, (624):223
48137, (625):1576927322, (626):1549294171, (627):1130063457, (628):1145453624, (
629):1650014768, (630):1482180427, (631):1583374935, (632):320300129, (633):1429
106195, (634):1835165041, (635):1533770097, (636):1870022941, (637):1027496812, 
(638):1078152525, (639):1734500450, (640):1869443947, (641):1179541870, (642):18
02267498, (643):1129798762, (644):1499093827, (645):1465470291, (646):910642528,
 (647):994000451, (648):1263556933, (649):1684366951, (650):1852725569, (651):20
54976363, (652):2122087291, (653):1870298494, (654):511408758, (655):2088664655,
 (656):1886548859, (657):1953731704, (658):2103929710, (659):1987672697, (660):2
071360630, (661):2004317559, (662):1996715636, (663):1953790185, (664):200431858
2, (665):2054646645, (666):2088598906, (667):1650356085, (668):1230594401, (669)
:1632782139, (670):1550019435, (671):1497588583, (672):1213685082, (673):8597197
41, (674):1851810145, (675):1784768871, (676):1801083998, (677):1514868850, (678
):472387856, (679):253171233, (680):252582677, (681):811208468, (682):1800019481
, (683):1919972719, (684):1584756594, (685):607809365, (686):958735652, (687):18
01934910, (688):2004448107, (689):1291937651, (690):-33533951, (691):1448499806,
 (692):1263295838, (693):1078018114, (694):1801867338, (695):1128553321, (696):1
416386117, (697):240017506, (698):1698632468, (699):1802792810, (700):1887203692
, (701):1276990831, (702):1718316919, (703):1312436028, (704):1683569466, (705):
1802334052, (706):1685024628, (707):1818910274, (708):1381590124, (709):14652752
19, (710):1802594663, (711):1196445526, (712):707674178, (713):1212758319, (714)
:1683641161, (715):1852471390, (716):2020830574, (717):2071756408, (718):2122153
596, (719):2054912634, (720):2122063390, (721):1886813053, (722):1821667957, (72
3):1785557877, (724):2138864507, (725):2021094775, (726):2038069370, (727):58094
970, (728):1954081143, (729):2004382835, (730):1835823479, (731):1953723765, (73
2):1802335866, (733):1533438315, (734):1212107093, (735):944462166, (736):121348
5393, (737):1263621192, (738):858996508, (739):1532121157, (740):1633772132, (74
1):1482906982, (742):488601193, (743):1127944492, (744):404179000, (745):2535001
79, (746):403902251, (747):1645811232, (748):1920103537, (749):1853125742, (750)
:610491989, (751):454762276, (752):1934042142, (753):2054845555, (754):23752562,
 (755):5374307, (756):1448564478, (757):1313759062, (758):1195919687, (759):1414
811461, (760):1381525348, (761):1868316480, (762):1298426476, (763):320018464, (
764):1869312618, (765):2104516203, (766):1466920803, (767):1936945462, (768):794
323570, (769):1010978364, (770):1953260896, (771):2054254190, (772):1414099317, 
(773):1347307855, (774):1414614350, (775):1533501271, (776):1146054008, (777):96
1039695, (778):607533898, (779):1431391557, (780):1616992599, (781):1919708270, 
(782):2139061111, (783):2071821178, (784):2054847356, (785):2054912886, (786):20
37741950, (787):-1686670480, (788):1852929649, (789):-2139325846, (790):20546510
09, (791):2004318843, (792):2004253561, (793):2021095544, (794):57833334, (795):
1819388024, (796):1936945771, (797):1903326581, (798):1802202984, (799):15504121
36, (800):1768252761, (801):1382052723, (802):1061902424, (803):1465340486, (804
):760829286, (805):1476611655, (806):1751279287, (807):525367669, (808):18969446
68, (809):423655538, (810):437984539, (811):588788567, (812):756627993, (813):19
53854577, (814):1936748917, (815):622797117, (816):286333733, (817):1126965023, 
(818):2054582899, (819):1835888503, (820):1392599553, (821):1431413504, (822):16
84628567, (823):1398232398, (824):641814864, (825):1579494183, (826):1936747087,
 (827):1886088567, (828):1263811176, (829):1852990029, (830):-881786004, (831):1
897489274, (832):1936878956, (833):1903391862, (834):1330196843, (835):173436525
6, (836):1734831732, (837):1752526186, (838):1229079114, (839):1364478792, (840)
:1549029711, (841):1785359456, (842):1212826449, (843):1245922378, (844):1111901
511, (845):1599489847, (846):1684301413, (847):2088335217, (848):2088467837, (84
9):58358137, (850):2071700856, (851):1937407612, (852):2054316919, (853):1802522
229, (854):2105244523, (855):2071822461, (856):1567192436, (857):2021292912, (85
8):2021095288, (859):57834362, (860):1903682168, (861):1970698601, (862):1920103
542, (863):1836215396, (864):2051825001, (865):1633837171, (866):1749769565, (86
7):1010653288, (868):1246185310, (869):1061438045, (870):1650086225,
(871):1836083807, (872):475814255, (873):1918832957, (874):403730544,
(875):404233503, (876
):438384909, (877):1075198021, (878):2004513908, (879):1802333559, (880):6256760
63, (881):353440037, (882):1043409946, (883):474839571, (884):1835888201, (885):
1291930369, (886):1380908544, (887):1785026392, (888):1314020454, (889):13462592
71, (890):320149290, (891):1886152747, (892):1835757173, (893):1499490926, (894)
:1886480464, (895):1836151663, (896):1209629552, (897):2037346162, (898):1987671
928, (899):1246457207, (900):1598966607, (901):1852731757, (902):1869636971, (90
3):1347307877, (904):1532315724, (905):1633246312, (906):1785028446, (907):13808
64091, (908):1632326483, (909):1836083304, (910):1633639002, (911):1734632544, (
912):2037871979, (913):2071690363, (914):1954117751, (915):2071689846, (916):193
7472893, (917):1920167010, (918):1918400421, (919):2021158498, (920):2038462842,
 (921):1752462456, (922):2138859585, (923):2004316794, (924):2138535800, (925):2
021292159, (926):2003921264, (927):1912829047, (928):1912825985, (929):163430037
2, (930):1785689978, (931):1851612514, (932):1381132651, (933):1666932814, (934)
:1247372133, (935):1582252090, (936):1667328361, (937):1667127651, (938):1953456
720, (939):290156152, (940):303505440, (941):555882520, (942):253388333, (943):1
953723505, (944):1533899382, (945):1261244474, (946):303110949, (947):947090244,
 (948):813130588, (949):1108877338, (950):21430614, (951):1425932373, (952):1818
123100, (953):1465870440, (954):1414154060, (955):1631143256, (956):1582372137, 
(957):1767927669, (958):1802333804, (959):1868455012, (960):1970368368, (961):13
16514934, (962):1869705799, (963):2054714995, (964):1819569016, (965):1095584593
, (966):1953520181, (967):1785293936, (968):1634168432, (969):1430805084, (970):
1601136995, (971):1482384738, (972):1583701594, (973):1583242331, (974):17684498
90, (975):1465539427, (976):1684498276, (977):2004119405, (978):2071755641, (979
):2054780794, (980):1937208951, (981):2122152814, (982):1987342714, (983):165200
1906, (984):1966428261, (985):2038398837, (986):1946449271, (987):1970628848, (9
88):1987277178, (989):-2139983752, (990):1987934845, (991):1970501494, (992):197
0500473, (993):1953920629, (994):1970632566, (995):1937537657, (996):1869771382,
 (997):1683906154, (998):1684497505, (999):1298487135, (1000):1228487230, (1001)
:1213814099, (1002):1802134628, (1003):1937143915, (1004):407067997, (1005):4208
80160, (1006):589438482, (1007):1376726335, (1008):1918202228, (1009):370217285,
 (1010):270733328, (1011):739578640, (1012):1551463282, (1013):291142526, (1014)
:739449117, (1015):22479196, (1016):1455489117, (1017):1633771611, (1018):146514
6467, (1019):1195854417, (1020):1632520522, (1021):1515731278, (1022):1617261921
, (1023):1769239403, (1024):1852728168, (1025):1212362864, (1026):1853388662, (1
027):1903393352, (1028):1987605871, (1029):2036887160, (1030):1364609895, (1031)
:1834235985, (1032):1835887734, (1033):1772317699, (1034):1466657382, (1035):183
5429220, (TIND):1, (DIND):2, (IND):-1
TOTAL: 1038

debugfs:   
--- >8 --- snap ---
Comment 17 Stephen Tweedie 2001-08-24 12:55:01 EDT
Thanks.  It should be fairly easy for me to reproduce the situation from this:
it looks as if we've got a simple case of an indirect block getting clobbered by
data contents.
Comment 18 Nils Philippsen 2002-03-13 09:01:12 EST
I removed anything I could from lost+found and it didn't crash (so I closed it as
ERRATA), but there are still files (equally weird modes,sizes,etc.) it wouldn't
delete. Shall I file a new bug, revive this one or try anything else?
Comment 19 Stephen Tweedie 2002-03-13 09:16:17 EST
Reopen this bug if there's still stuff that goes wrong, definitely.
Comment 20 Stephen Tweedie 2002-11-15 07:34:49 EST
*** Bug 74294 has been marked as a duplicate of this bug. ***
Comment 21 Stephen Tweedie 2003-02-03 13:33:24 EST
Found it.  I had tried to reproduce this with a corrupt blocks list, to no
avail.  It turns out that it's the "i_blocks" field going negative which results
in the assert failure, due to a kernel bug where it treats that value as signed
(i_blocks is actually supposed to be unsigned.)

Fix attached to bug #82238.

*** This bug has been marked as a duplicate of 82238 ***
Comment 22 Red Hat Bugzilla 2006-02-21 13:48:06 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.