Bug 523781 - qspice patch does not apply cleanly
Summary: qspice patch does not apply cleanly
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: qspice
Version: 5.4
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Uri Lublin
QA Contact: yeylon@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-16 16:25 UTC by Jeroen van Meeuwen
Modified: 2016-04-18 06:26 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-12 07:23:25 UTC


Attachments (Terms of Use)
The patch that does not apply cleanly (18.54 KB, text/plain)
2009-09-16 16:25 UTC, Jeroen van Meeuwen
no flags Details
Rejected hunk on libspice/snd_worker.c (756 bytes, text/plain)
2009-09-16 16:26 UTC, Jeroen van Meeuwen
no flags Details
Rejected hunk on libspice/vd_interface.h (620 bytes, text/plain)
2009-09-16 16:27 UTC, Jeroen van Meeuwen
no flags Details

Description Jeroen van Meeuwen 2009-09-16 16:25:34 UTC
Created attachment 361317 [details]
The patch that does not apply cleanly

Description of problem:

qspice-0.3.0-39.el5.src.rpm does not recompile, because patch #10, qspice-0.3.0-add-log-proc-to-CoreInterface.patch fails 2 hunks:

DEBUG: Patch #10 (qspice-0.3.0-add-log-proc-to-CoreInterface.patch):
DEBUG: + /bin/cat /builddir/build/SOURCES/qspice-0.3.0-add-log-proc-to-CoreInterface.patch
DEBUG: + /usr/bin/patch -s -p1 -b --suffix .add-log-proc-to-CoreInterface --fuzz=0
DEBUG: 1 out of 2 hunks FAILED -- saving rejects to file libspice/snd_worker.c.rej
DEBUG: 1 out of 6 hunks FAILED -- saving rejects to file libspice/vd_interface.h.rej
DEBUG: RPM build errors:
DEBUG: error: Bad exit status from /var/tmp/rpm-tmp.1eQfgd (%prep)
DEBUG:     Bad exit status from /var/tmp/rpm-tmp.1eQfgd (%prep)
DEBUG: Child returncode was: 1

Version-Release number of selected component (if applicable):

qspice-0.3.0-39.el5

How reproducible:

mock -v -r epel-5-i386 rebuild qspice-0.3.0-39.el5.src.rpm, or rpmbuild --rebuild qspice-0.3.0-39.el5.src.rpm

Steps to Reproduce:
1. Download source rpm
2. Attempt rebuild
3.
  
Actual results:

Failed applying patch #10

Expected results:

Succeeded rebuild

Additional info:

Attempting to recompile the stack for Fedora 11, so that it can be submitted for review to, and finally inclusion in, Fedora

Comment 1 Jeroen van Meeuwen 2009-09-16 16:26:27 UTC
Created attachment 361318 [details]
Rejected hunk on libspice/snd_worker.c

Attached failed hunk #1

Comment 2 Jeroen van Meeuwen 2009-09-16 16:27:26 UTC
Created attachment 361320 [details]
Rejected hunk on libspice/vd_interface.h

Attached rejected hunk #2

Comment 3 Uri Lublin 2009-09-22 14:52:14 UTC
If you remove "--fuzz=0" from the "patch" command it works. Also works with "--fuzz=1".

Note that qspice is only supported for Red Hat Enterprise Linux 5.4 x86_64, so the build may fail for i386 or for 5.3

Comment 4 Uri Lublin 2009-10-12 07:23:25 UTC
On the next release we'll be using a new tar file and patches on top of it should apply cleanly.

Comment 5 Jeroen van Meeuwen 2009-10-12 07:39:45 UTC
I was trying to get the package in Fedora, so could you point me to the upstream location?

Comment 6 Uri Lublin 2009-10-12 08:27:09 UTC
There is no upstream yet.
Soon...


Note You need to log in before you can comment on or make changes to this bug.