Bug 523836 - loud crack when starting sound
Summary: loud crack when starting sound
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 11
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jaroslav Kysela
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 522481 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-16 19:51 UTC by Pablo Mandiola
Modified: 2009-09-29 14:34 UTC (History)
6 users (show)

Fixed In Version: 2.6.30.8-64.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-29 14:34:00 UTC


Attachments (Terms of Use)
alsa-info --no-upload output (14.91 KB, text/plain)
2009-09-17 02:46 UTC, Pablo Mandiola
no flags Details

Description Pablo Mandiola 2009-09-16 19:51:22 UTC
Description of problem:
Whenever I start playing something, there's a single crack before the sound starts.

For example, when I'm using Pidgin every notification starts with a cracking noise. However, if I'm in Rhythmbox there's a single crack only when I start playing, there's no crack between songs and there's even no crack in Pidgin's notifications while playing.

It happens with every sound, even in the gdm screen when asking for the password and the login sound.

It seems to be something with the sound card waking up. The problem happens with both speakers and headphones. 

Version-Release number of selected component (if applicable):
pulseaudio-0.9.15-17

How reproducible:
Always

Steps to Reproduce:
1.Play any sound
2.
3.
  
Actual results:
Cracking noise before sound starts

Expected results:
Sound plays without any crack

Additional info:

Comment 1 Lennart Poettering 2009-09-16 20:55:57 UTC
Sounds like a driver/hw artifact that happens when PA initiailizes the audio device.

Please appand the output of alsa-info.sh --no-upload here.

Comment 2 Pablo Mandiola 2009-09-17 02:46:36 UTC
Created attachment 361415 [details]
alsa-info --no-upload output

Comment 3 Pablo Mandiola 2009-09-22 23:48:55 UTC
Do you need any other information for this bug?

Comment 4 Chuck Ebbert 2009-09-24 13:47:19 UTC
Audio powersave was enabled by default in kernel 2.6.30 ... I assume the problem started after updating the kernel?

You can disable it like this:

# echo "0" >/sys/module/snd_hda_intel/parameters/power_save

It's now disabled by default in kernel 2.6.30.7-59 and later.

Comment 5 Pablo Mandiola 2009-09-25 00:04:38 UTC
Thanks for your answer!

Yes, the problem started after an update, but I thought it was pulseaudio's update and not the kernel.. Maybe both updated at the same time and I just blamed pulseaudio.

I did what you suggested but the problem is still there.

Comment 6 Chuck Ebbert 2009-09-25 04:29:38 UTC
*** Bug 522481 has been marked as a duplicate of this bug. ***

Comment 7 Pablo Mandiola 2009-09-25 15:49:25 UTC
This workaroud solves the problem, but when I restart it's back again. Is there a way to set the parameter to 0 permanently?

Comment 8 Fedora Update System 2009-09-25 16:01:57 UTC
kernel-2.6.30.8-64.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/kernel-2.6.30.8-64.fc11

Comment 9 Pablo Mandiola 2009-09-27 21:46:38 UTC
Problem solved updating kernel to version 2.6.30.8-64.fc1. Thanks!

Comment 10 Fedora Update System 2009-09-29 14:33:12 UTC
kernel-2.6.30.8-64.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.