Bug 52388 - up2date-nox enhancment idea
up2date-nox enhancment idea
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
: FutureFeature
: 52258 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-23 08:33 EDT by Viral
Modified: 2015-01-07 18:51 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-05 16:20:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Viral 2001-08-23 08:33:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0; DigExt)

Description of problem:
I think up2date-nox could do with being able to show the current file in 
download along side it's progress bar.  For people on a slow connection 
this is not much help determining remaining time (REAL remaining time, not 
the built in estimate, as it is never correct on choppy links like ISDN..):

########################## Done.                   
########################## Done.                   
########################## Done.                   
#                            7 k/sec, 00:10:02 rem.

but perhaps:
grip-9.5-3          [##########] Done.
kdebase-2.2-4       [######    ]
est time left       [5 months 6 days...]

I really think this would be a BIG improvment on this fantastic program, 
if I could just look at my ssh and then at the list of updates I'd alreddy 
printed/saved and think, "oh, half way down the list then" then it would 
be better than "2 hours 8 minuts?  I wonder if it MEENS that this time.."

Cheers!


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. .
2. .
3. .
	

Actual Results:  .

Expected Results:  .

Additional info:

.
Comment 1 Warren Togami 2001-08-23 08:52:01 EDT
I agree.  Please add filenames and some sort of progress meter.  I spent over 
an hour yesterday wondering how long the process would take.  There is 
currently no indicator of filenames and/or % complete, which can be frustrating 
when you're on a time constraint.  (i.e. Should I up2date install for 
convenience, or find the CD, mount, install? -- or -- Do I have time to grab a 
bite to eat before I can access my RPM database again?)
Comment 2 Warren Togami 2001-08-23 08:53:04 EDT
Sorry, one tiny question, is that "7 k/sec" kilobits or kilobytes?
Comment 3 Viral 2001-08-23 09:12:38 EDT
Erm, not a clue, but my average speed on up2date has often been 7kbps as with 
any "fast download" on my isdn.  So it must be KBPS?  Bloody best be!
Comment 4 Jay Turner 2001-08-23 09:25:18 EDT
Those stats should be showing in kilobytes/sec.
Comment 5 Adrian Likins 2001-08-23 14:48:31 EDT
The next version of the client will show the names of the packages
alongside the hashes again.

(already does so in cvs...)
Comment 6 Adrian Likins 2001-08-24 15:21:17 EDT
*** Bug 52258 has been marked as a duplicate of this bug. ***
Comment 7 David M. Cook 2001-11-06 15:01:30 EST
However, you still get only hash marks if the packages are already in
/var/spool/up2date.
Comment 8 Adrian Likins 2001-11-06 16:26:57 EST
okay, this should be fixed for local packages as well in CVS now.
Comment 10 Gene Czarcinski 2003-11-11 08:21:03 EST
shouldn't this be closed?
Comment 11 Adrian Likins 2004-04-05 16:20:54 EDT
closed, old. 99% of original rfe is done, as I understand it.
If not, open a new bug.

Note You need to log in before you can comment on or make changes to this bug.