Bug 52405 - xmouse-mode should not be used - focus ok but not text cursor if pointer out of dialog
Summary: xmouse-mode should not be used - focus ok but not text cursor if pointer out ...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-23 16:02 UTC by Enrico Scholz
Modified: 2007-04-18 16:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-09 04:36:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrico Scholz 2001-08-23 16:02:47 UTC
In current version, anaconda gives the focus to the window where the
mouse-pointer is over. This makes no sense because there is only one active
window, but it causes ergonomical problems:

- go to the "Configure account" screen
- "Add" a new user -> an "Add a new user" dialog appears
- move mouse into the upper right corner of the screen
- try to find the edit-field with the input-focus

If the "Add a new user" window would keep the focus after the mouse was
moved away, the current edit-field would have a cursor indicating the
input-focus.

Comment 1 Brent Fox 2001-08-23 19:44:35 UTC
Can't fix now. Deferring.  We don't have a window manager running in the
install, so fixing this might be hard.

Comment 2 Brent Fox 2001-10-26 22:17:10 UTC
I believe that this is a limitation of GTK, not the installer.  I think you'll
see the same behavior in the disk partitioning screen.  Perhaps the switch to
GTK2 will solve this problem.  We are using the GTK Dialog widget now instead of
the Gnome Dialog widget.

Comment 3 Matt Wilson 2002-02-06 20:26:48 UTC
should be fixed in beta2


Comment 4 Michael Fulbright 2002-06-12 20:44:00 UTC
The entries keep the focus, but the cursor is not shown.  I believe this would
require a window manager to be running, which we do not plan on doing for this
release.

Comment 5 Jeremy Katz 2003-07-09 04:36:11 UTC
This should be fixed now.


Note You need to log in before you can comment on or make changes to this bug.